Description

Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.

Input

Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.

Output

Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.

Sample Input

4 2 1
1 3 10
2 4 20
2 3 3

Sample Output

27

Hint

Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.

Source

USACO 2005 December Gold

现学现卖

参考博客:https://www.cnblogs.com/wjhstudy/p/9757046.html

https://blog.csdn.net/I_believe_CWJ/article/details/81369021

把所有不等式转化为x-y<=z

有向图!

1.ml:

建一条从x到y的边,权值为z,x是较小的坐标,y是较大的坐标。

max(x,y)-min(x,y)<=z

2.md:

建一条从x到y的边,权值为-z,x是较大的坐标,y是较小的坐标。

max(x,y)-min(x,y)>=z

min(x,y)-max(x,y)<=-z

 

附:x-y<z ==> x-y<=z-1

建好图跑一遍spfa就完了,所求1到n的 最短路 即二者之间 距离 最大值。

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <queue>
using namespace std;
const int N=1e4+50;
const int inf=0x3f3f3f3f;
int dis[N],vis[N],head[N],num[N];
int n,maxx,minn,tot;
struct Edge
{
    int u,v,w,next;
}edge[N];

void add(int a,int b,int c)
{
    edge[tot].u=a;
    edge[tot].v=b;
    edge[tot].w=c;
    edge[tot].next=head[a];
    head[a]=tot++;
}

bool spfa(int s)
{
    queue<int>q;
    for(int i=1;i<=n;i++)
        dis[i]=inf;
    memset(vis,false,sizeof(vis));
    memset(num,0,sizeof(num));
    q.push(s);
    dis[s]=0;
    while(!q.empty())
    {
        int pos=q.front();
        q.pop();
        vis[pos]=false;
        num[pos]++;
        for(int i=head[pos];i!=-1;i=edge[i].next)
        {
            if(dis[edge[i].v]>dis[edge[i].u]+edge[i].w)
            {
                dis[edge[i].v]=dis[edge[i].u]+edge[i].w;
                if(!vis[edge[i].v])
                {
                    vis[edge[i].v]=true;
                    q.push(edge[i].v);
                    if(num[edge[i].v]>=n)
                        return false;
                }
            }
        }
    }
    return true;
}
int main()
{
    while(scanf("%d%d%d",&n,&maxx,&minn)!=EOF)
    {
        int a,b,c;
        tot=0;
        memset(head,-1,sizeof(head));
        while(maxx--)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(a>b)
                swap(a,b);
            add(a,b,c);
//            cout<<a<<' '<<b<<' '<<c<<'\n';
        }
        while(minn--)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(a<b)
                swap(a,b);
            add(a,b,-c);
//            cout<<a<<' '<<b<<' '<<c<<'\n';
        }
        if(!spfa(1))
            cout<<-1<<'\n';
        else if(dis[n]==inf)
            cout<<-2<<'\n';
        else
            cout<<dis[n]<<'\n';
    }
    return 0;
}