题干:

A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary. 
You are to find all the hat’s words in a dictionary. 

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words. 
Only one case. 

Output

Your output should contain all the hat’s words, one per line, in alphabetical order.

Sample Input

a
ahat
hat
hatword
hziee
word

Sample Output

ahat
hatword

题目大意:

给你n个按字典序排列的单词,问你其中的所有能由另外两个单词组成的单词并按字典序输出(字符串按照字典序读入的)

解题报告:

  因为题目说读入的字符串最多一行(80个字符?反正我设了55个字符过了),所以直接暴力就行了,假设单个字符串平均长度为len,那复杂度是O(50000/len * (len*len)) 也就是O(50000*len),所以题目如果只说了一共50000个字符,没说每个字符串的长度,那就需要对每个字符处理的时候先预处理出一个东西。

对每个串正着扫一遍 pre[i]存[0,i]有没有出现过,再对每个串反着在第二棵树里扫一遍 suf[i]存[i,len-1]有没有出现过,如果pre[i]&suf[i+1] 那这个串就符合条件

AC代码:

#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
const int MAX = 50000 + 5;
char s[MAX];
int trie[MAX][55];
int cnt[MAX];
char ss[MAX][55];//????
int tot,n;
void insert(char str[]) {
	int rt = 0;
	int len = strlen(str);
	for(int i = 0; i<len; i++) {
		int cur = str[i] - 'a';
		if(!trie[rt][cur]) trie[rt][cur] = ++tot;
		rt = trie[rt][cur];
	}
	cnt[rt]++;
}
int ask(char str[]) {
	int rt = 0;
	int len = strlen(str);
	for(int i = 0; i<len; i++) {
		int cur = str[i] - 'a';
		if(!trie[rt][cur]) return -1;
		rt = trie[rt][cur];
	}
	return cnt[rt];
}
int main()
{
	while(~scanf("%s",s)) {
		strcpy(ss[++n],s);
		insert(s);
	}
	for(int i = 1; i<=n; i++) {
		int len = strlen(ss[i]);
		int flag = 0;
		for(int j = 0; j<len-1; j++) {
			char tmp[55];
			memset(tmp,0,sizeof tmp);
			for(int k = 0; k<=j; k++) tmp[k] = ss[i][k];//赋值过来 
			if(ask(tmp) == 1) {
				memset(tmp,0,sizeof tmp);
				for(int k = j+1; k<len; k++) tmp[k-(j+1)] = ss[i][k];
				if(ask(tmp) == 1) {
					flag = 1;
					break;
				}
			}
		}
		if(flag) printf("%s\n",ss[i]);
	}

	return 0 ;
}

对于字符串处理那一部分,可以用strncpy函数。

功能:将字符串from 中至多count个字符复制到字符串to中。如果字符串from 的长度小于count,其余部分用'\0'填补。返回处理完成的字符串。