Song Jiang's rank list

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 1463    Accepted Submission(s): 808


Problem Description
《Shui Hu Zhuan》,also 《Water Margin》was written by Shi Nai'an -- an writer of Yuan and Ming dynasty. 《Shui Hu Zhuan》is one of the Four Great Classical Novels of Chinese literature. It tells a story about 108 outlaws. They came from different backgrounds (including scholars, fishermen, imperial drill instructors etc.), and all of them eventually came to occupy Mout Liang(or Liangshan Marsh) and elected Song Jiang as their leader.

In order to encourage his military officers, Song Jiang always made a rank list after every battle. In the rank list, all 108 outlaws were ranked by the number of enemies he/she killed in the battle. The more enemies one killed, one's rank is higher. If two outlaws killed the same number of enemies, the one whose name is smaller in alphabet order had higher rank. Now please help Song Jiang to make the rank list and answer some queries based on the rank list.
 

Input
There are no more than 20 test cases.

For each test case:

The first line is an integer N (0<N<200), indicating that there are N outlaws.

Then N lines follow. Each line contains a string S and an integer K(0<K<300), meaning an outlaw's name and the number of enemies he/she had killed. A name consists only letters, and its length is between 1 and 50(inclusive). Every name is unique.

The next line is an integer M (0<M<200) ,indicating that there are M queries.

Then M queries follow. Each query is a line containing an outlaw's name.
The input ends with n = 0
 

Output
For each test case, print the rank list first. For this part in the output ,each line contains an outlaw's name and the number of enemies he killed.

Then, for each name in the query of the input, print the outlaw's rank. Each outlaw had a major rank and a minor rank. One's major rank is one plus the number of outlaws who killed more enemies than him/her did.One's minor rank is one plus the number of outlaws who killed the same number of enemies as he/she did but whose name is smaller in alphabet order than his/hers. For each query, if the minor rank is 1, then print the major rank only. Or else Print the major rank, blank , and then the minor rank. It's guaranteed that each query has an answer for it.
 

Sample Input
5 WuSong 12 LuZhishen 12 SongJiang 13 LuJunyi 1 HuaRong 15 5 WuSong LuJunyi LuZhishen HuaRong SongJiang 0
 

Sample Output
HuaRong 15 SongJiang 13 LuZhishen 12 WuSong 12 LuJunyi 1 3 2 5 3 1 2
 

Source


思路:
给定N个人的姓名和他的杀敌数,然后按照杀敌数从大到小排序,数值相同的,名字字典序小的排在前。然后先把排序的结果输出。再来M个询问,每个询问是查询某个人的排名,排名由两部分构成。第一部分是求出杀敌数比他大的人数+1,第二部分是跟他杀敌数相同但排名比他靠前的人数+1,如果第二部分的答案是1,则不用输出。
网上看到了一个做法是重载了> 、< 运算符。。真的是机智啊。。。。原来的大于小于号只能判断数值,你重载了使它能判断数值和字符串的字典序之后实际上就相当于了一个简单排序题。。。太他妈机智了。。。

代码:
#include<cstring>  
#include<cstdio>  
#include<algorithm>  
#include<map>  
#include<string>  
using namespace std;  
map<string,int> MP;  
struct Name{  
    char s[60];  
    int v;  
    bool operator < (const Name &A)const{  
        return v>A.v || (v==A.v && strcmp(s, A.s)<=0);  
    }  
}p[300];  
char s[60];  
int main(){  
    int n, m;  
    while(~scanf("%d", &n) && n){  
        MP.clear();  
        for(int i=0; i<n; i++){  
            scanf("%s %d", p[i].s, &p[i].v);  
            MP[p[i].s] = p[i].v;  
        }  
        sort(p, p+n);  
        for(int i=0; i<n; i++)   printf("%s %d\n", p[i].s, p[i].v);  
        scanf("%d", &m);  
        int a, b, c;  
        while(m--){  
            a = b = 0;  
            scanf("%s", s);  
            c = MP[s];  
            for(int i=0; i<n; i++){  
                if(strcmp(p[i].s, s)==0)    break;  
                if(p[i].v>c) a++;  
                else    b++;  
            }  
            printf("%d", a+1);  
            if(b)   printf(" %d", b+1);  
            puts("");  
        }  
    }  
    return 0;  
}