PAT A1046. Shortest Distance (20)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 … DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.
Sample Input:

5 1 2 4 14 9
3
1 3
2 5
4 1

Sample Output:

3
10
7
#include <iostream>
#include <algorithm>
#include <vector>


using namespace std;




int main(){


    int n,m;

    cin>>n;

    vector<int> dis(n+10); 

    int sum=0;
    dis[0]=0;
    for(int i=1;i<=n;i++){

        int temp;
        cin>>temp;
        sum+=temp;
        dis[i]=sum; 


    }


    cin>>m;

    for(int i=0;i<m;i++){
        int start,end;
        cin>>start>>end;

        int dis1=0,dis2=0,res;

        if(start>end){
            swap(start,end);
        }

        dis1=dis[end-1]-dis[start-1];

        dis2=sum-dis1;

        res=min(dis1,dis2);


        cout<<res<<endl;



    }






    return 0;
}