Problem Description
A simple problem
Problem Description
You have a multiple set,and now there are three kinds of operations:
1 x : add number x to set
2 : delete the minimum number (if the set is empty now,then ignore it)
3 : query the maximum number (if the set is empty now,the answer is 0)
 

Input
The first line contains a number  N ( N106),representing the number of operations.
Next  N line ,each line contains one or two numbers,describe one operation.
The number in this set is not greater than  109.
 

Output
For each operation 3,output a line representing the answer.
 

Sample Input
6 1 2 1 3 3 1 3 1 4 3
 

Sample Output
3 4
 


好像这个题当时是做错了一直被我遗弃到现在 >_< 刚刚看了一遍WA代码 发现自己错在把优先队列的优先级弄错了T^T  top是最大的!top是最大的!top是最大的重要的事情说三遍!他说删最小的 查询最大的 模拟一下就好啦 

#include <iostream>
#include<cstdio>
#include<queue>
using namespace std;

int n,a,b,sum;
int main()
{
    while(~scanf("%d",&n))
    {
        priority_queue<int>que;
        sum=0;
        while(n--)
        {
            scanf("%d",&a);
            if(a==1)
            {
                scanf("%d",&b);
                que.push(b);
                sum++;
            }
            else if(a==2)
            {
                if(sum)
                sum--;
            }
            else if(a==3)
            {
                if(sum)
                printf("%d\n",que.top());
                else printf("0\n");
            }
            if(sum==0)
            {
                while(!que.empty()) que.pop();
            }
        }
    }
    return 0;
}