Cow Multiplication

Time Limit: 1000MS Memory Limit: 65536K

Description

Bessie is tired of multiplying pairs of numbers the usual way, so she invented her own style of multiplication. In her style, AB is equal to the sum of all possible pairwise products between the digits of A and B. For example, the product 12345 is equal to 14 + 15 + 24 + 25 + 34 + 35 = 54. Given two integers A and B (1 ≤ A, B ≤ 1,000,000,000), determine A*B in Bessie’s style of multiplication.

Input

  • Line 1: Two space-separated integers: A and B.

Output

  • Line 1: A single line that is the A*B in Bessie’s style of multiplication.

Sample Input

123 45

Sample Output

54

#include <iostream>
#include <cstdio>
#include <string>
using namespace std;
int main() {
    ios::sync_with_stdio;
    string n, m;
    int sum = 0;
    cin >> n >> m;
    for (int i = 0; i < n.size(); i++) {
        for (int j = 0; j < m.size(); j++) {
            sum += (n[i] - '0') * (m[j] - '0');
        }
    }
    printf("%d", sum);
    return 0;
}