The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?
Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.
The input terminates by end of file marker.
Output
For each test case, output an integer indicating the final points of the power.
Sample Input
3 1 50 500
Sample Output
0 1 15
Hint
From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499", so the answer is 15.
题意:和上一篇类似,稍微一改就是,这是要49,,给你一个区间,问里面包含49的数有多少个
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <map>
#include <vector>
#include <queue>
using namespace std;
typedef long long ll;
const int maxn=1e5+5;
ll dp[20][2];
int a[20];
ll dfs(int pos,int pre,int sta,int limit)
{
if(pos==-1)return 1;
if(!limit&&dp[pos][sta]!=-1) return dp[pos][sta];
int up=limit?a[pos]:9;
ll ans=0;
for(int i=0;i<=up;i++)
{
if(pre==4&&i==9)continue;
ans+=dfs(pos-1,i,i==4,limit&&i==a[pos]);
}
if(!limit) dp[pos][sta]=ans;
return ans;
}
ll solve(ll x)
{
int pos=0;
while(x)
{
a[pos++]=x%10;
x/=10;
}
return dfs(pos-1,1,0,1);
}
int main()
{
int T;
ll x;
scanf("%d",&T);
while(T--)
{
memset(dp,-1,sizeof(dp));
scanf("%lld",&x);
printf("%lld\n",x-solve(x)+(ll)1);
}
return 0;
}