题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1263
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

夏天来了~~好开心啊,呵呵,好多好多水果~~
Joe经营着一个不大的水果店.他认为生存之道就是经营最受顾客欢迎的水果.现在他想要一份水果销售情况的明细表,这样Joe就可以很容易掌握所有水果的销售情况了.

Input

第一行正整数N(0<N<=10)表示有N组测试数据.
每组测试数据的第一行是一个整数M(0<M<=100),表示工有M次成功的交易.其后有M行数据,每行表示一次交易,由水果名称(小写字母组成,长度不超过80),水果产地(小写字母组成,长度不超过80)和交易的水果数目(正整数,不超过100)组成.

Output

对于每一组测试数据,请你输出一份排版格式正确(请分析样本输出)的水果销售情况明细表.这份明细表包括所有水果的产地,名称和销售数目的信息.水果先按产地分类,产地按字母顺序排列;同一产地的水果按照名称排序,名称按字母顺序排序.
两组测试数据之间有一个空行.最后一组测试数据之后没有空行.

Sample Input

1
5
apple shandong 3
pineapple guangdong 1
sugarcane guangdong 1
pineapple guangdong 3
pineapple guangdong 1

Sample Output

guangdong
   |----pineapple(5)
   |----sugarcane(1)
shandong
   |----apple(3)

Problem solving report:

Description: 求出水果销售情况的明细表,包括水果产地,水果名称和销售情况。
Problem solving: 利用二维map索引,添加数据后遍历map。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
int main() {
    char name[85], site[85];
    int n, m, t, num;
    scanf("%d", &t);
    while (t--) {
        map <string, map <string, int>> spt;
        scanf("%d", &n);
        for (int i = 0; i < n; i++) {
            scanf("%s%s%d", name, site, &num);
            spt[site][name] += num;
        }
        map <string, map <string, int>>::iterator ita;
        for (ita = spt.begin(); ita != spt.end(); ita++) {
            printf("%s\n", ita -> first.c_str());
            map <string, int>::iterator itb;
            for (itb = ita -> second.begin(); itb != ita -> second.end(); itb++) {
                printf("   |----%s(%d)\n", itb -> first.c_str(), itb -> second);
            }
        }
        if (t)
            printf("\n");
    }
    return 0;
}