题干:

We all know that Bin-Laden is a notorious terrorist, and he has disappeared for a long time. But recently, it is reported that he hides in Hang Zhou of China! 
“Oh, God! How terrible! ” 



Don’t be so afraid, guys. Although he hides in a cave of Hang Zhou, he dares not to go out. Laden is so bored recent years that he fling himself into some math problems, and he said that if anyone can solve his problem, he will give himself up! 
Ha-ha! Obviously, Laden is too proud of his intelligence! But, what is his problem? 
“Given some Chinese Coins (硬币) (three kinds-- 1, 2, 5), and their number is num_1, num_2 and num_5 respectively, please output the minimum value that you cannot pay with given coins.” 
You, super ACMer, should solve the problem easily, and don’t forget to take $25000000 from Bush! 

Input

Input contains multiple test cases. Each test case contains 3 positive integers num_1, num_2 and num_5 (0<=num_i<=1000). A test case containing 0 0 0 terminates the input and this test case is not to be processed. 

Output

Output the minimum positive value that one cannot pay with given coins, one line for one case. 

Sample Input

1 1 3
0 0 0

Sample Output

4

题目大意:

给你cnt1个一元硬币,cnt2个两元硬币,cnt3个五元硬币,问不能凑出来的第一个面额是多少。

解题报告:

         母函数。

AC代码:

#include<cstdio>
#include<queue>
#include<cstring>
#include<cmath>
#include<iostream>
#include<algorithm>
using namespace std;
int a[8005],b[8005];//b是中间值 
int c[3];//1  2  5的数量
int d[3] = {1,2,5}; 
int n,m;
int main()
{
	int t;
	while(cin>>c[0]>>c[1]>>c[2]) {
		if(c[0] + c[1] + c[2] == 0) break;
		memset(a,0,sizeof a);
		memset(b,0,sizeof b);
		for(int i = 0; i<=c[0]; i++) {
			a[i]=1,b[i]=0;
		} 
		int maxx = c[0] + c[1]*2 + c[2]*5;
		for(int i = 1; i<=2; i++) {
			for(int j = 0; j<=maxx; j++) {
				if(a[j]==0) continue;//剪枝 
				for(int k = 0; k<=c[i]; k++) {
					b[j+k*d[i]] += a[j];
				}
			}
			for(int j = 0; j<=maxx; j++) {
				a[j]=b[j];b[j]=0;
			}
//			for(int i = 0; i<=m; i++) printf("%d ",a[i]);
//			printf("\n");
		}
		int flag = 0;
		for(int i = 0; i<=maxx; i++) {
			if(a[i] == 0) {
				flag=1;printf("%d\n",i);break;
			}
		}
		if(flag ==0) printf("%d\n",maxx+1);
	}
	return 0;
}

稍微优化一点的代码:(但是还是15ms)

#include <iostream>
#include <cstring>
using namespace std;
int n[3],a[9000],b[9000],i,j,k,last,last2;
int v[3]={1,2,5};
int main()
{
	while ((cin>>n[0]>>n[1]>>n[2])&&(n[0]!=0||n[1]!=0|n[2]!=0))
	{
		a[0]=1;
		last=0;
		for (i=0;i<=2;i++)
		{
			last2=last+n[i]*v[i];
			memset(b,0,sizeof(int)*(last2+1));
			for (j=0;j<=n[i];j++)
				for (k=0;k<=last;k++)
					b[k+j*v[i]]+=a[k];
			memcpy(a,b,sizeof(int)*(last2+1));
			last=last2;
		}
		for (i=0;i<=last;i++)
			if (a[i]==0)
				break;
		cout<<i<<endl;
	}
	return 0;
}