Relatives

Time Limit: 1000MS Memory Limit: 65536K

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

题意:

给一个n,在n中有多少个x, y符合x > 1, y > 0, z > 0 , a = xy and b = xz, y, z不存在。

思路:

由于不存在a = xy and b = xz, 所以也就是说x = 1 或者 x = 0(题目x > 1),x = 0不可能,所以x = 1,所以就有gcd(a, b) = 1, a, b互质,接着写个欧拉函数就行了。

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int main() {
    int n;
    while (scanf("%d", &n) != EOF && n) {
        int res = n;
        for (int i = 2; i * i <= n; i++) {
            if (n % i == 0) res = res / i * (i - 1);
            while (n % i == 0) n /= i;
        }
        if (n > 1) res = res / n * (n - 1);
        printf("%d\n", res);
    }
    return 0;
}