题意:这里
Problem Description
XOR is a kind of bit operator, we define that as follow: for two binary base number A and B, let C=A XOR B, then for each bit of C, we can get its value by check the digit of corresponding position in A and B. And for each digit, 1 XOR 1 = 0, 1 XOR 0 = 1, 0 XOR 1 = 1, 0 XOR 0 = 0. And we simply write this operator as ^, like 3 ^ 1 = 2,4 ^ 3 = 7. XOR is an amazing operator and this is a question about XOR. We can choose several numbers and do XOR operatorion to them one by one, then we get another number. For example, if we choose 2,3 and 4, we can get 2^3^4=5. Now, you are given N numbers, and you can choose some of them(even a single number) to do XOR on them, and you can get many different numbers. Now I want you tell me which number is the K-th smallest number among them.

Input
First line of the input is a single integer T(T<=30), indicates there are T test cases.
For each test case, the first line is an integer N(1<=N<=10000), the number of numbers below. The second line contains N integers (each number is between 1 and 10^18). The third line is a number Q(1<=Q<=10000), the number of queries. The fourth line contains Q numbers(each number is between 1 and 10^18) K1,K2,……KQ.

Output
For each test case,first output Case #C: in a single line,C means the number of the test case which is from 1 to T. Then for each query, you should output a single line contains the Ki-th smallest number in them, if there are less than Ki different numbers, output -1.

Sample Input

2
2
1 2
4
1 2 3 4
3
1 2 3
5
1 2 3 4 5

Sample Output

Case #1:
1
2
3
-1
Case #2:
0
1
2
3
-1

Hint

If you choose a single number, the result you get is the number you choose.
Using long long instead of int because of the result may exceed 2^31-1.

解法:
先搞出来线性基,然后第k大的异或和就是:
把k二进制拆分,第i位上有1,就把第i个线性基异或进来。

//HDU 3949

#include <bits/stdc++.h>
using namespace std;
const int maxn = 10010;
typedef long long LL;
LL a[maxn]; //线形基
int n; //n个数
void Guass(){//高斯消元求线形基
    int i, j, k, t;
    k = 0;
    for(i = 62; i >= 0; i--){
        for(j = k; j < n; j++){
            if((a[j] >> i) & 1) break;
        }
        if(j < n){
            swap(a[j], a[k]);
            for(t = 0; t < n; t++){
                if(t != k && ((a[t] >> i) & 1)) a[t] ^= a[k];
            }
            k++;
        }
    }
    sort(a, a + n); n = unique(a, a + n) - a;
}
LL cal(LL k){
    LL ans; int i; ans = i = 0;
    if(a[0] == 0){//特判0不能异或出来《=》线形基的大小和原数组一样
        if(k == 1) return 0;
        k--; i++;
    }
    for(; i < n && k; k >>= 1, i++){
        if(k&1) ans ^= a[i];
    }
    if(i == n && k) return -1;
    return ans;
}
int main()
{
    int T, q, ks = 0;
    scanf("%d", &T);
    while(T--){
        scanf("%d", &n);
        for(int i = 0; i < n; i++) scanf("%I64d", &a[i]);
        Guass();
        scanf("%d", &q);
        printf("Case #%d:\n", ++ks);
        while(q--){
            LL k;
            scanf("%I64d", &k);
            printf("%I64d\n", cal(k));
        }
    }
    return 0;
}