House Building

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1207    Accepted Submission(s): 757


Problem Description
Have you ever played the video game Minecraft? This game has been one of the world's most popular game in recent years. The world of Minecraft is made up of lots of 1×1×1 blocks in a 3D map. Blocks are the basic units of structure in Minecraft, there are many types of blocks. A block can either be a clay, dirt, water, wood, air, ... or even a building material such as brick or concrete in this game.

<center> </center>
<center> Figure 1: A typical world in Minecraft. </center>

Nyanko-san is one of the diehard fans of the game, what he loves most is to build monumental houses in the world of the game. One day, he found a flat ground in some place. Yes, a super flat ground without any roughness, it's really a lovely place to build houses on it. Nyanko-san decided to build on a n×m big flat ground, so he drew a blueprint of his house, and found some building materials to build.

While everything seems goes smoothly, something wrong happened. Nyanko-san found out he had forgotten to prepare glass elements, which is a important element to decorate his house. Now Nyanko-san gives you his blueprint of house and asking for your help. Your job is quite easy, collecting a sufficient number of the glass unit for building his house. But first, you have to calculate how many units of glass should be collected.

There are n rows and m columns on the ground, an intersection of a row and a column is a 1×1 square,and a square is a valid place for players to put blocks on. And to simplify this problem, Nynako-san's blueprint can be represented as an integer array ci,j(1in,1jm). Which ci,j indicates the height of his house on the square of i-th row and j-th column. The number of glass unit that you need to collect is equal to the surface area of Nyanko-san's house(exclude the face adjacent to the ground).
 

Input
The first line contains an integer T indicating the total number of test cases.
First line of each test case is a line with two integers n,m.
The n lines that follow describe the array of Nyanko-san's blueprint, the i-th of these lines has m integers ci,1,ci,2,...,ci,m, separated by a single space.

1T50
1n,m50
0ci,j1000
 

Output
For each test case, please output the number of glass units you need to collect to meet Nyanko-san's requirement in one line.
 

Sample Input
2 3 3 1 0 0 3 1 2 1 1 0 3 3 1 0 1 0 0 0 1 0 1
 

Sample Output
30 20 <center> </center> <center> Figure 2: A top view and side view image for sample test case 1. </center>
 

Source


思路:
题意啰嗦了一大堆,但是实际上要求的很简单,就是求一个立方体的表面积(底面除外)。就是算每一个突起来的地方比他周围高多少就完。WA了一发是因为数组开小了。。

代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int a[105][105];

int main()
{
	int num;
	while(cin>>num)
	{
		while(num--)
		{
			long long sum=0;
			int x;
			int y;
			scanf("%d%d",&x,&y);
			memset(a,0,sizeof(a));
			for(int i=1;i<=x;i++)
				for(int j=1;j<=y;j++)
				{
					scanf("%d",&a[i][j]);
				}
			for(int i=1;i<=x;i++)
				for(int j=1;j<=y;j++)
				{
					if(a[i][j]==0)continue;
					sum++;
					if(a[i][j]>a[i-1][j])
					{
						sum=sum+a[i][j]-a[i-1][j];
					}
					if(a[i][j]>a[i+1][j])
					{
						sum=sum+a[i][j]-a[i+1][j];
					}
					if(a[i][j]>a[i][j-1])
					{
						sum=sum+a[i][j]-a[i][j-1];
					}
					if(a[i][j]>a[i][j+1])
					{
						sum=sum+a[i][j]-a[i][j+1];
					}															
				}
			printf("%lld\n",sum);
		}
	}
	return 0;
}