Description
Mato同学最近正在研究一种矩阵,这种矩阵有n行n列第i行第j列的数为gcd(i,j)。
例如n=5时,矩阵如下:

1 1 1 1 1
1 2 1 2 1
1 1 3 1 1
1 2 1 4 1
1 1 1 1 5

Mato想知道这个矩阵的行列式的值,你能求出来吗?

Input

一个正整数n mod1000000007
Output

n行n列的Mato矩阵的行列式。

Sample Input
5

Sample Output
16

HINT

对于100%的数据,n<=1000000。

解法:按照题目给的方法构造行列式先高斯消元,发现消出来的上3角矩阵的对角线的值恰好为欧拉序列,由于数据大,

直接线性筛了一发欧拉函数。

///BZOJ 3288

#include <bits/stdc++.h>
using namespace std;
//int n, a[100][100];
//void Guass(){
// int i,j,k,r;
// for(int i=0; i<n; i++){
// r=i;
// while(r<n&&!a[r][i]) r++;
// if(r!=i) for(j=0; j<n; j++) swap(a[r][j], a[i][j]);
// for(k=i+1; k<n; k++){
// int f=a[k][i]/a[i][i];
// for(j=i; j<n; j++) a[k][j]-=f*a[i][j];
// }
// }
//}
//int main()
//{
// while(cin>>n){
// for(int i=0; i<n; i++){
// for(int j=0; j<n; j++){
// a[i][j]=__gcd(i+1,j+1);
// }
// }
// Guass();
// for(int i=0; i<n; i++){
// for(int j=0; j<n; j++){
// printf("%d ", a[i][j]);
// }
// printf("\n");
// }
// }
//}

const int maxn = 1000010;
const int mod=1e9+7;
int n;
long long ans=1;
int phi[maxn], pri[maxn], tot;
bool mark[maxn];

void xianxingsai(){
    phi[1]=1;
    for(int i=2; i<maxn; i++){
        if(!mark[i]){
            pri[++tot]=i;
            phi[i]=i-1;
        }
        for(int j=1; j<=tot&&i*pri[j]<maxn; j++){
            mark[i*pri[j]]=1;
            if(i%pri[j]==0){
                phi[i*pri[j]]=phi[i]*pri[j];
                break;
            }
            phi[i*pri[j]]=phi[i]*(pri[j]-1);
        }
    }
}

int main()
{
    scanf("%d", &n);
    xianxingsai();
    for(int i=1; i<=n; i++){
        ans=ans*1LL*phi[i]%mod;
    }
    ans%=mod;
    printf("%lld\n", ans);
    return 0;
}