题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2594
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.

Sample Input

clinton homer
riemann marjorie

Sample Output

0
rie 3

Problem solving report:

Description: 给出s1,s2两个串 求出既为s1的前缀又为s2后缀的子串。
Problem solving: 直接用s1当模式串去匹配s2,当s2匹配之后,此时s1匹配的长度就是子串的长度。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
const int MAXN = 50005;
int nex[MAXN];
char sa[MAXN], sb[MAXN];
void Next(int n) {
    nex[0] = -1;
    int i = 0, j = -1;
    while (i < n) {
        if (~j && sb[i] != sb[j])
            j = nex[j];
        else nex[++i] = ++j;
    }
}
int KMP(int la, int lb) {
    Next(lb);
    int i = 0, j = 0;
    while (i < la) {
        if (~j && sa[i] != sb[j])
            j = nex[j];
        else i++, j++;
    }
    return j;
}
int main() {
    int n, la, lb;
    while (~scanf("%s%s", sb, sa)) {
        la = strlen(sa);
        lb = strlen(sb);
        int m = KMP(la, lb);
        if (!m)
            printf("0\n");
        else {
            sb[m] = '\0';
            printf("%s %d\n", sb, m);
        }
    }
    return 0;
}