Problem Description
soda has a set  S with  n integers  {1,2,,n}. A set is called key set if the sum of integers in the set is an even number. He wants to know how many nonempty subsets of  S are key set.
 

Input
There are multiple test cases. The first line of input contains an integer  T  (1T105), indicating the number of test cases. For each test case:

The first line contains an integer  n  (1n109), the number of integers in the set.
 

Output
For each test case, output the number of key sets modulo 1000000007.
 

Sample Input
4 1 2 3 4
 

Sample Output
0 1 3 7
 


纯数学题 ,尝试着找公式,失败,据说这是这是找规律的题,貌似之前也见到过类似的写几个数就看出来端倪的orz

这个题更是……

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define MOD 1000000007
long long mod(long long a,long long b)
{
    long long ans=1;
    while(b)
    {
        if(b&1) ans=(ans*a)%MOD;
        b/=2;
        a=(a*a)%MOD;
    }
    return ans;
}
int main()
{
    int t;
    long long n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        cout<<mod(2,n-1)-1<<endl;
    }
    return 0;
}