题目链接:

http://poj.org/problem?id=3104

题面:

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

翻译:

有n件衣服需要晾干,每件衣服含水量 aia_i,每件衣服每分钟自然风干 1 单位的水,每分钟可以对其中任意一件衣服使用吹风机,其可以减少 k 单位的水,求晾干所有衣服的最少时间。

数据规模:

1n1000001ai1091k1091 \leq n \leq 100000 \\ 1 \leq a_i \leq 10^9 \\ 1 \leq k \leq 10^9

分析+代码:

二分枚举答案+检验;
注意二分条件判断
注意数据规模(输入输出建议用printf\scanf);
边界特例(k=1)会导致TLE(RE);

//#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;

typedef long long ll;

int n;
int k;
int a[100010] = {};

/*
   
> 注意判断可行性的过程:
   > 
   > 1.先把所有衣服的含水量减去T
   > 2.然后把>=(k-1)的拿去烘干,可以理解为烘干时候每分钟掉(k-1)水,
   	这样所有的衣服都每分钟自然干掉1水了。
   	因为每分钟掉一滴水是肯定的了,因此,如果你去烘干它的话,
   	那么它就能再掉多k-1 + 1 == k,这样才是k滴水,然后就是计算总花费时间
   > 3.最后判断总花费时间时候小于T,若小于等于,则可行性,否则不可行.

在用 烘 干 机 的同时不会自然风干

*/

bool check(int mid) {
   ll cnt = 0;
   for (int i = 1; i <= n; i++) {
   	if (a[i] > mid) {
   		cnt += (a[i]-mid) / (k-1);  // 
   		if ((a[i]-mid) % (k-1)) {
   			cnt++;
   		}
   	}
   }
   
   if (cnt <= mid) return false;
   else return true;
   
}

int main () {
   
//	std::ios::sync_with_stdio(0), cin.tie(0), cout.tie(0);
   
//	while (cin.peek() != EOF) {
//		cin >> n;
   while (scanf("%d", &n) != EOF) {
   	
   	int mx = 0;

   	for (int i = 1; i <= n; i++) {
//			cin >> a[i]; 
   		scanf("%d", &a[i]);
   		mx = max(mx, a[i]);
   		
   	} 
//		cin >> k;
   	scanf("%d", &k);
   	
   	if (k == 1) {  // 特例判断,防止时间越界
   		printf("%d\n", mx);
   		continue;
   	}
   	
   	int l = 1, r = mx;
   	
   	while (l <= r) {
   		
   		int mid = (l + r) >> 1;
   		
   		if (check(mid)) 
   			l = mid + 1;
   		else 
   			r = mid - 1;
   	}
   	
   	printf("%d\n", l);
   	
   }
   
   return 0;
}