Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N).

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using “not” operation (if it is a ‘0’ then change it into ‘1’ otherwise change it into ‘0’). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions.

  1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2).
  2. Q x y (1 <= x, y <= n) querys A[x, y].

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case.

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format “Q x y” or “C x1 y1 x2 y2”, which has been described above.
Output

For each querying output one line, which has an integer representing A[x, y].

There is a blank line between every two continuous test cases.
Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1
Sample Output

1
0
0
1


一道二维线段树或者树状数组。

树状数组:我们每次修改一个矩阵时,我们可以利用差分的思想,只修改4个点,然后要查询某个点的值,求前缀和即可。
线段树:直接区间修改即可。


这道题我们每次0->1 , 1->0比较麻烦,所以我们直接+1即可,最后答案%2.


AC代码:

#pragma GCC optimize(2)
#include<stdio.h>
#include<string.h>
//#define int long long
#define lowbit(x) (x&(-x))
using namespace std;
const int N=1010;
int T,t[N][N],n,m;
inline void add(int x,int y,int v){
	for(int i=x;i<=n;i+=lowbit(i)){
		for(int j=y;j<=n;j+=lowbit(j))	t[i][j]+=v;
	}
}
inline int ask(int x,int y){
	int res=0;
	for(int i=x;i;i-=lowbit(i)){
		for(int j=y;j;j-=lowbit(j))	res+=t[i][j];
	}
	return res%2;
}
signed main(){
	scanf("%d",&T);
	while(T--){
		memset(t,0,sizeof t);
		scanf("%d %d",&n,&m);
		while(m--){
			char op[2]; scanf("%s",op);
			if(op[0]=='C'){
				int x1,x2,y1,y2;	scanf("%d %d %d %d",&x1,&y1,&x2,&y2);
				add(x1,y1,1); add(x1,y2+1,-1); 
				add(x2+1,y1,-1); add(x2+1,y2+1,1);
			}else{
				int x,y;	scanf("%d %d",&x,&y);	printf("%d\n",ask(x,y));
			}
		}
		puts("");
	}
	return 0;
}