题干:
What a sunny day! Let’s go picnic and have barbecue! Today, all kids in “Sun Flower” kindergarten are prepared to have an excursion. Before kicking off, teacher Liu tells them to stand in a row. Teacher Liu has an important message to announce, but she doesn’t want to tell them directly. She just wants the message to spread among the kids by one telling another. As you know, kids may not retell the message exactly the same as what they was told, so teacher Liu wants to see how many versions of message will come out at last. With the result, she can evaluate the communication skills of those kids.
Because all kids have different height, Teacher Liu set some message passing rules as below:
1.She tells the message to the tallest kid.
2.Every kid who gets the message must retell the message to his “left messenger” and “right messenger”.
3.A kid’s “left messenger” is the kid’s tallest “left follower”.
4.A kid’s “left follower” is another kid who is on his left, shorter than him, and can be seen by him. Of course, a kid may have more than one “left follower”.
5.When a kid looks left, he can only see as far as the nearest kid who is taller than him.
The definition of “right messenger” is similar to the definition of “left messenger” except all words “left” should be replaced by words “right”.
For example, suppose the height of all kids in the row is 4, 1, 6, 3, 5, 2 (in left to right order). In this situation , teacher Liu tells the message to the 3rd kid, then the 3rd kid passes the message to the 1st kid who is his “left messenger” and the 5th kid who is his “right messenger”, and then the 1st kid tells the 2nd kid as well as the 5th kid tells the 4th kid and the 6th kid.
Your task is just to figure out the message passing route.
Input
The first line contains an integer T indicating the number of test cases, and then T test cases follows.
Each test case consists of two lines. The first line is an integer N (0< N <= 50000) which represents the number of kids. The second line lists the height of all kids, in left to right order. It is guaranteed that every kid’s height is unique and less than 2^31 – 1 .
Output
For each test case, print “Case t:” at first ( t is the case No. starting from 1 ). Then print N lines. The ith line contains two integers which indicate the position of the ith (i starts form 1 ) kid’s “left messenger” and “right messenger”. If a kid has no “left messenger” or “right messenger”, print ‘0’ instead. (The position of the leftmost kid is 1, and the position of the rightmost kid is N)
Sample Input
2
5
5 2 4 3 1
5
2 1 4 3 5
Sample Output
Case 1:
0 3
0 0
2 4
0 5
0 0
Case 2:
0 2
0 0
1 4
0 0
3 0
解题报告:
其实这题很重要的一个点在于,孩子的身高各不相同,所以不需要考虑单调栈是否严格单调递减等问题、、接下来就是单调栈的基本操作了。
AC代码1:(源自网络)
#include<set>
#include<map>
#include<ctime>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const double eps = 1e-8;
const int INF = 0x7FFFFFFF;
//const int mod = 1e9 + 7;
const int N = 5e5;
int T, n, a[N], L[N], R[N], cas = 0;
int main()
{
scanf("%d", &T);
while (T--)
{
scanf("%d", &n);
stack<int> p;
rep(i, 1, n) scanf("%d", &a[i]), L[i] = R[i] = 0;
rep(i, 1, n)
{
while (!p.empty() && a[p.top()] < a[i])
{
int q = p.top(); p.pop();
if (!p.empty()) R[p.top()] = q;
}
p.push(i);
}
while (!p.empty())
{
int q = p.top(); p.pop();
if (!p.empty()) R[p.top()] = q;
}
per(i, n, 1)
{
while (!p.empty() && a[p.top()] < a[i])
{
int q = p.top(); p.pop();
if (!p.empty()) L[p.top()] = q;
}
p.push(i);
}
while (!p.empty())
{
int q = p.top(); p.pop();
if (!p.empty()) L[p.top()] = q;
}
printf("Case %d:\n", ++cas);
rep(i, 1, n) printf("%d %d\n", L[i], R[i]);
}
return 0;
}
AC代码2:(自己)
#include<bits/stdc++.h>
using namespace std;
const int MAX = 50000+ 5;
int a[MAX],L[MAX],R[MAX];
int tmp;
stack<int > sk;
void init() {
for(int i = 1; i<MAX; i++) {
L[i]=R[i]=0;
}
}
int main()
{
int t ;
cin>>t;
int iCase=0;
while(t--) {
init();
while(!sk.empty() ) sk.pop();
int n;
scanf("%d",&n);
for(int i = 1; i<=n; i++) {
scanf("%d",&a[i]);
}
for(int i = 1; i<=n; i++) {
//找从左到右第一个比他大的,所以从左到右维护一个单调递减栈。
while(!sk.empty() && a[sk.top() ] <a[i] ) sk.pop();
if(sk.empty() ) L[i] = 0;
else L[sk.top() ] = i;
sk.push(i);
}
while(!sk.empty() ) sk.pop();
for(int i = n; i>=1; i--) {
//从右向左找第一个比他大的,所以从右向左维护一个单调递减栈。
while(!sk.empty() && a[sk.top() ]<a[i] ) sk.pop();
if(sk.empty() ) R[i] = 0;
else R[sk.top() ] = i;
sk.push(i);
}
printf("Case %d:\n",++iCase);
for(int i = 1; i<=n; i++) {
printf("%d %d\n",R[i],L[i]);
}
}
return 0 ;
}
AC代码3:(依旧是单调栈)
#include<bits/stdc++.h>
using namespace std;
const int MAX = 50000 + 5;
int n;
int a[MAX];
int l[MAX],r[MAX];
int main()
{
int t;
int iCase = 0;
cin>>t;
while(t--) {
scanf("%d",&n);
for(int i = 1; i<=n; i++) {
scanf("%d",&a[i]);
}
memset(l,0,sizeof(l));
memset(r,0,sizeof(r));
stack<int > sk;
for(int i = 1; i<=n; i++) {
while(!sk.empty() && a[sk.top()] < a[i]) {
l[i] = sk.top();
sk.pop();
}
sk.push(i);
}
while(!sk.empty()) sk.pop();
for(int i = n; i>=1; i--) {
while(!sk.empty() && a[sk.top()] < a[i]) {
r[i] = sk.top();
sk.pop();
}
sk.push(i);
}
printf("Case %d:\n",++iCase);
for(int i = 1; i<=n; i++) {
printf("%d %d\n",l[i],r[i]);
}
}
return 0 ;
}
//14:40 - 14:57
二分:https://blog.csdn.net/kongming_acm/article/details/5780543
#include<iostream>#include<cstdio>using namespace std;int a[50100],_left[50100],_right[50100];int n;void search(int l,int r,int id,int flag){ // cout<<l<<"...."<<r<<"..."<<id<<"..."<<flag<<endl; int m=0,p=0; for(int i=l;i<=r;i++) { if(a[i]<a[id]&&a[i]>m) { m=a[i]; p=i; } } if(!flag) _left[id]=p; else _right[id]=p; if(p) { search(l,p-1,p,0); search(p+1,r,p,1); }}int main(){ int ci;scanf("%d",&ci); for(int pl=1;pl<=ci;pl++) { scanf("%d",&n); int m=0,p=0; for(int i=1;i<=n;i++) { scanf("%d",&a[i]); if(a[i]>m) { m=a[i]; p=i; } } search(1,p-1,p,0); search(p+1,n,p,1); printf("Case %d:/n",pl); for(int i=1;i<=n;i++) printf("%d %d/n",_left[i],_right[i]); } return 0;}
---------------------
本文来自 kongming_acm 的CSDN 博客 ,全文地址请点击:https://blog.csdn.net/kongming_acm/article/details/5780543?utm_source=copy
总结:
1.还是要进一步熟悉单调栈的用法。