Description

In the planet Pandora, Jake found an old encryption algorithm. The plaintext, key and ciphertext are all four decimal numbers and all greater than 0. The way to get the ciphertext from the plaintext and the key is very simple: the ciphertext is the last four digits of the product of the plaintext and the key (for example: the plaintext is 2010 and the key is 4024, and then the product is 8088240. So the ciphertext is 8240).

Note that the plaintext and the key don’t have leading 0, while the ciphertext might have. Now given the plaintext and the key, you are asked to figure out the ciphertext for Jake quickly.

Input

The first line is an integer T, which presents the number of test cases. Then there are T lines, each line has two integers, the first integer is the plaintext and the second is the key.

Output

For each test case, output the ciphertext.

Sample Input

2
2010 4024
1234 1111

Sample Output

8240
0974

Hint


两数相乘,取模10000就可以了
#include<stdio.h>
#include<string>
#include<string.h>
#include<algorithm>
#include<iostream>
typedef long long ll;
using namespace std;
ll x, y;
int main()
{
	int t;
	while (~scanf("%d", &t))
	{
		while (t--)
		{
			scanf("%lld%lld", &x, &y);
			ll num = x*y;
			num = num % 10000;
			printf("%.4lld\n", num);
		}
	}
	return 0;
}
/**********************************************************************
	Problem: 1018
	User: leo6033
	Language: C++
	Result: AC
	Time:0 ms
	Memory:2024 kb
**********************************************************************/