Problem Description

An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.

Examples: Assume an alphabet that has symbols {A, B, C, D}

The following code is immediately decodable: 
A:01 B:10 C:0010 D:0000

but this one is not: 
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)

Input

Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).

Output

For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.

Sample Input

01 
10 
0010 
0000 

01 
10 
010 
0000 
9

Sample Output

Set 1 is immediately decodable 
Set 2 is not immediately decodable

题目大意

给你一堆2进制编码,判断是否任何一组编码都不是其他编码的前缀。 9表示结束一次判断的结束。

字典树

#include <stdio.h>
#include <string.h>
struct node
{
    int flag ;
    node *next[2] ;
};
node *newnode()
{
    node *p = new node ;
    p->flag = 0 ;
    p->next[0] = NULL ;
    p->next[1] = NULL ;
    return p ;
}
int gettree(node *root,char *s)
{
    int i , l = strlen(s);
    node *p = root ;
    for(i = 0 ; i < l ; i++)
    {
        int k = s[i]-'0' ;
        if(p->flag)
        {
            return 0;
        }
        if(p->next[k]==NULL)
            p->next[k] = newnode() ;
        p = p->next[k] ;
    }
    if(p->next[0] == NULL && p->next[1] == NULL && p->flag == 0)
    {
        p->flag = 1 ;
        return 1 ;
    }
    else
        return 0 ;
}
int main()
{
    int i , n = 0 , num = 0;
    char s[20][20] ;
    node *head;
    while(scanf("%s", s[n++])!=EOF)
    {
        if(s[n-1][0] != '9') ;
        else
        {
            n-- ; num++;
            head = newnode();
            for(i = 0 ; i < n ; i++)
            {
                int k = gettree(head,s[i]);
                if(k==0) break;
            }
            if(i==n)
                printf("Set %d is immediately decodable\n", num);
            else
                printf("Set %d is not immediately decodable\n", num);
            n = 0 ;
        }
    }
}

map映射

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<string>
#include<map>
using namespace std;
char a[20];
int main()
{
    int b,n;
    map<string,int>m;
    string s[1000];
    b=0,n=0;
    while(gets(a))
    {
        if(a[0]!='9')
        {
            m[a]++;
            s[b]=a;
            b++;
            for(int i=strlen(a)-1;i>0;i--)
            {
                a[i]='\0';
                m[a]++;
            }
        }
        else
        {
            n++;
            while(b--)
            {
                if(m[s[b]]!=1)
                    break;
            }
            if(b<0)
                printf("Set %d is immediately decodable\n",n);
            else
                printf("Set %d is not immediately decodable\n",n);
            b=0;
            map<string,int>m;
        }
    }
    return 0;
}