1076 Forwards on Weibo (30 point(s))

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]
where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

思路:

本题要求你求微博的转发的用户最多的人,但是不能超过题目给定的层数,所以可以用结构体存层数以及用户id(在bfs遍历的时候使用),在存用户的关注信息的时候用vector存储,v[i][j]中i用于存储某个用户, j用于存储关注的人的数量,v[i][j]的值用于存储关注的用户的用户名,样例的最后一行是查询的数量以及用户名,遍历的时候用的邻接表的方法。

邻接表版

#include <iostream>
#include <queue>
#include <vector>
using namespace std;
struct NODE {
	int id;
	int layer;
};
vector<int> v[1010];
void bfs(int start, int L) {
	bool book[1010] = {false};
	queue<NODE> q;
	int sum = 0;
	NODE top = {start, 0};
	book[top.id] = true;
	q.push(top);
	while (!q.empty()) {
		top = q.front();
		q.pop();
		int u = top.id;
		for (int i = 0; i < v[u].size(); i++) {
			NODE next = {v[u][i], top.layer + 1};
			if (next.layer <= L && book[next.id] == false) {
				sum++;
				book[next.id] = true;
				q.push(next);
			}
		}
	}
	cout << sum << endl;
} 
int main() {
	int n, m, k, findnum;
	scanf("%d %d", &n, &m);
	for (int i = 1; i <= n; i++) { 
		scanf("%d", &k);
		while (k--) {
			int id;
			scanf("%d", &id);
			v[id].push_back(i);
		}
	}
	scanf("%d", &findnum);
	while (findnum--) {
		int id;
		scanf("%d", &id);
		bfs(id, m);
	}
	return 0;
}

邻接矩阵版

(代码区别不大,但是时间复杂度大了很多)

#include <iostream>
#include <queue>
#include <vector>
#include <cstring>
using namespace std;
struct NODE {
	int id;
	int layer;
};
int v[1010][1010];
int n, m;
void bfs(int start, int L) {
	bool book[1010] = {false};
	queue<NODE> q;
	int sum = 0;
	NODE top = {start, 0};
	book[top.id] = true;
	q.push(top);
	while (!q.empty()) {
		top = q.front();
		q.pop();
		int u = top.id;
		for (int i = 1; i <= n; i++) {
			NODE next = {i, top.layer + 1};
			if (next.layer <= L && v[u][i] == 1 && book[i] == false) {
				sum++;
				book[next.id] = true;
				q.push(next);
			}
		}
	}
	cout << sum << endl;
} 
int main() {
	int k, findnum;
	scanf("%d %d", &n, &m);
	memset(v, 0, sizeof(v));
	for (int i = 1; i <= n; i++) { 
		scanf("%d", &k);
		while (k--) {
			int id;
			scanf("%d", &id);
			v[id][i] = 1;
		}
	}
	scanf("%d", &findnum);
	while (findnum--) {
		int id;
		scanf("%d", &id);
		bfs(id, m);
	}
	return 0;
}