Given you n sets.All positive integers in sets are not less than 1 and not greater than m.If use these sets to combinate the new set,how many different new set you can get.The given sets can not be broken.
Input
There are several cases.For each case,the first line contains two positive integer n and m(1<=n<=100,1<=m<=14).Then the following n lines describe the n sets.These lines each contains k+1 positive integer,the first which is k,then k integers are given. The input is end by EOF.
Output
For each case,the output contain only one integer,the number of the different sets you get.
Sample Input
4 4
1 1
1 2
1 3
1 4
2 4
3 1 2 3
4 1 2 3 4
Sample Output
15
2
题意:给你n个集合 求这n个集合有多少并集
题解:状态压缩 将每一个集合压缩为二进制 如1,3,7就是 1000101
类似于哈希表那样的过程 然后vis标记一下 每次添加新的集合的时候跟已有的集合全部取一下并集
最后所有集合的个数就是答案
#include <bits/stdc++.h>
using namespace std;
int vis[1<<15];
int main(){
int n,m;
while(scanf("%d%d",&n,&m)!=EOF){
memset(vis,0,sizeof(vis));
for(int i=0;i<n;i++){
int k,w=0;
scanf("%d",&k);
for(int j=0;j<k;j++){
int num;
scanf("%d",&num);
w+=1<<(num-1);
}
vis[w]=1;
for(int j=1;j<1<<15;j++){
if(vis[j])vis[j|w]=1;
}
}
int ans=0;
for(int i=1;i<1<<15;i++){
if(vis[i])ans++;
}
printf("%d\n",ans);
}
return 0;
}