The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.

Input

The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.

Output

For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.

Sample Input

4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0

Sample Output

NO
YES

题意:

         S为起点,D为终点,.为可走的路,X为障碍。判断小狗是否能在规定时间到达终点,不能走 走过的路。

思路:

       需要奇偶剪枝,我没有剪加了一个判断条件,利用深度优先搜索就行了。

一开始没有增加判断条件导致时间超限了一次,后来加了条件之后还是WA非常纳闷,找了好几遍才发现是k定义为全局变量了。

代码:

#include<stdio.h>  
#include<string.h> 
int n,m,t,flag,sx,sy,ex,ey;
int book[10][10];
char str[10][10];
void dfs(int x,int y,int step) 
{	
	if(flag==1)
		return;  
	int nx,ny,k;
 	int next[4][2]={{0,1},
	  				{1,0},
					{0,-1},
					{-1,0}};
	if(str[x][y]=='D')
	{
		if(step==t)
			flag=1;       
		return;		
	}   
	for(k=0;k<4;k++)     
	{         
		nx=x+next[k][0];         
		ny=y+next[k][1];         
		if(nx<0||nx>n||ny<0||ny>m)
			continue;
		if(book[nx][ny]==0&&(str[nx][ny]=='.'||str[nx][ny]=='D'))
		{
			book[nx][ny]=1;
			dfs(nx,ny,step+1);
			book[nx][ny]=0;
		}
	}     
	return; 
} 
int main() 
{    
	int i,j; 
	while(scanf("%d%d%d",&n,&m,&t)!=EOF)    
	{
		memset(book,0,sizeof(book));
		flag=0;
		getchar();  
		if(n==0&&m==0&&t==0)             
			break; 
		for(i=1;i<=n;i++)         
		{                          
			for(j=1;j<=m;j++)
			{
				scanf("%c",&str[i][j]);
				if(str[i][j]=='S')
				{
					sx=i;
					sy=j;
				}
			}   
			getchar();         
		} 
		dfs(sx,sy,0);        
		if(flag==1)             
		printf("YES\n");         
		else             
		printf("NO\n");    
	} 
	return 0;
}