还是畅通工程
Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 54371    Accepted Submission(s): 24686


Problem Description

某省调查乡村交通状况,得到的统计表中列出了任意两村庄间的距离。省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可),并要求铺设的公路总长度为最小。请计算最小的公路总长度。

Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( < 100 );随后的N(N-1)/2行对应村庄间的距离,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间的距离。为简单起见,村庄从1到N编号。
当N为0时,输入结束,该用例不被处理。

Output
对每个测试用例,在1行里输出最小的公路总长度。

Sample Input


3
1 2 1
1 3 2
2 3 4
4
1 2 1
1 3 4
1 4 1
2 3 3
2 4 2
3 4 5
0

Sample Output

3

5

#include<bits/stdc++.h>
using namespace std;
struct  stu{
    int x;
    int y;
    int cost;
}; 
int f[105];
int find(int x){
	if(x!=f[x])
	f[x]=find(f[x]); 
	return f[x];
} 
bool unite(int x,int y){
	int fx=find(x);
	int fy=find(y);
	if(fx!=fy)
	{f[fx]=fy;
	 return true;
	}
	return false;
}
bool cmp(stu a,stu b){
	return a.cost<b.cost;
}
int main(){
	int n;
	stu r; 
	vector<stu> d;
	while(~scanf("%d",&n)&&n){
		d.clear();
		for(int i=1;i<=n;i++){
			f[i]=i;
		}
		int m=n*(n-1)/2;
		for(int i=1;i<=m;i++){
			scanf("%d%d%d",&r.x,&r.y,&r.cost);
			d.push_back(r);
		}
		sort(d.begin(),d.end(),cmp);
		int sum=0,cnt=0;
		for(int i=0;i<d.size();i++){
			if(unite(d[i].x,d[i].y)){
				sum+=d[i].cost;
				cnt++; 
			}
			if(cnt==n-1)
			break;
		}
		printf("%d\n",sum);
	}
	return 0;
}