Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 

Escaped in x minute(s).


where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 

Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

题意:

你被困在一个3D地牢中且继续寻找最短路径逃生!地牢由立方体单位构成,立方体中不定会充满岩石。向上下前后左右移动一个单位需要一分钟。你不能对角线移动并且迷宫四周坚石环绕。 
是否存在逃出生天的可能性?如果存在,则需要多少时间? 

解题思路:

和普通的二维BFS搜索类似,只不过增加了上下两个方向,存图时需要用三维数组

#pragma GCC optimize("O2")
#pragma G++ optimize("O2")

#include <cstdio>
#include <queue>
#include <cstring>
#include <algorithm>

using namespace std;
const int N = 30 + 7;

char g[N][N][N];    // 下标的先后顺序时 高 行 列
int used[N][N][N];
int l, r, c;

// 方向数组,标记上下左右前后六个方向
int d[6][3] = {1, 0, 0,  -1, 0, 0,  0, 1, 0,  0, -1, 0,  0, 0, 1,  0, 0, -1};

struct node{
    int x, y, z;
    int step;
    node(int k = 0, int i = 0, int j = 0, int s = 0) : z(k), x(i), y(j), step(s) {};    // 构造函数
    friend bool operator < (node p1, node p2)   // 重载小于 < 
    {
        return p1.step > p2.step;
    }
};

priority_queue<node> que;
int bfs(int z, int x, int y)    // 注意参数顺序
{
    memset(used, 0, sizeof(used));
    while(!que.empty()) que.pop();
    

    que.push(node(z, x, y, 0));
    used[z][x][y] = 1;
    while(!que.empty())
    {
        node now = que.top();   que.pop();
        if(g[now.z][now.x][now.y] == 'E')
            return now.step;
        for(int i=0; i<6; i++)
        {
            int dz = now.z + d[i][0];
            int dx = now.x + d[i][1];
            int dy = now.y + d[i][2];
            if(dz >= 0 && dz < l && dx >= 0 && dx < r && dy >= 0 && dy < c && !used[dz][dx][dy] && g[dz][dx][dy] != '#')
            {
                used[dz][dx][dy] = 1;
                que.push(node(dz, dx, dy, now.step + 1));

            }
        }
    }
    return -1;
}

int main()
{
    
    while(scanf("%d %d %d", &l, &r, &c), l + r + c)
    {
        for(int i=0; i < l; i++)
            for(int j=0; j < r; j++)
                scanf("%s", g[i][j]);   // 第 i 层 第 j行
        
        int x, y, z;
        for(int k=0; k < l; k++)
        {
            for(int i=0; i < r; i++)
            {
                for(int j=0; j < c; j++)
                {
                    if(g[k][i][j] == 'S')
                    {
                        z = k;
                        x = i;
                        y = j;
                    }
                }
            }
        }

        // printf("z = %d x = %d y = %d\n", z, x, y);

        int ans = bfs(z, x, y);
        if(ans == -1)
            printf("Trapped!\n");
        else 
            printf("Escaped in %d minute(s).\n", ans);
    }


    return 0;
}