Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题意:

一个竹竿长度为p,它的score值就是比p长度小且与且与p互质的数字总数,比如9有1,2,4,5,7,8这六个数那它的score就是6。给你T组数据,每组n个学生,每个学生都有一个幸运数字,求出要求买n个竹子每个竹子的score都要大于或等于该学生的幸运数字,每个竹竿长度就是花费,求最小花费。

思路:

先要知道欧拉函数是什么 ~~~当当当~~地址

假装你已经知道了,

emmm 举一个例子吧:2    4    5    6     7      9(上面是竹竿的长度,下面是对应的score值)

                                     3    5    7     7    11   11

   当P为质数时 , 欧拉函数值ψ(P)=P-1。所以可以先打表所有素数 , 然后去找大于该数最近的素数 , 再将它们相加即可。

贴代码:

#include <bits/stdc++.h>
using namespace std;
const int maxn = 1e6+8;
int a[maxn];
void shai()
{
	memset(a , 0 , sizeof(a));
	a[1] = 1;
	for(int i = 2 ; i <= sqrt(maxn) ; i++)
	{
		if(a[i] == 0)
		{
			for(int j = 2 ; i * j < maxn ; j++)
			{
				a[i*j] = 1;
			}
		}
	}
} 
int main()
{
	int t , n ;
	shai();
	scanf("%d" , &t);
	for(int j = 1 ; j <= t ; j++)
	{
		int x;
		long long ans = 0;
		scanf("%d" , &n);
		while(n--)
		{
			scanf("%d" , &x);
			for(int i = x+1 ; ; i++)
			{
				if(a[i] == 0)
				{
					ans += i;
				//	cout << "i = " << i << endl;
					break;
				}
			}
		}
	cout <<"Case "<< j <<": "<< ans<<" Xukha"<< endl;
	}
	return 0;
 }