题目

时间限制
200 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Li
宋代史学家司马光在《资治通鉴》中有一段著名的“德才论”:“是故才德全尽谓之圣人,才德兼亡谓之愚人,德胜才谓之君子,才胜德谓之小人。凡取人之术,苟不得圣人,君子而与之,与其得小人,不若得愚人。”
现给出一批考生的德才分数,请根据司马光的理论给出录取排名。
输入格式:
输入第1行给出3个正整数,分别为:N(<=10 <nobr aria&#45;hidden="true"> 5 </nobr> <math xmlns="http&#58;&#47;&#47;www&#46;w3&#46;org&#47;1998&#47;Math&#47;MathML"> <msup> <mn> 5 </mn> </msup> </math>),即考生总数;L(>=60),为录取最低分数线,即德分和才分均不低于L的考生才有资格被考虑录取;H(<100),为优先录取线——德分和才分均不低于此线的被定义为“才德全尽”,此类考生按德才总分从高到低排序;才分不到但德分到线的一类考生属于“德胜才”,也按总分排序,但排在第一类考生之后;德才分均低于H,但是德分不低于才分的考生属于“才德兼亡”但尚有“德胜才”者,按总分排序,但排在第二类考生之后;其他达到最低线L的考生也按总分排序,但排在第三类考生之后。
随后N行,每行给出一位考生的信息,包括:准考证号、德分、才分,其中准考证号为8位整数,德才分为区间[0, 100]内的整数。数字间以空格分隔。

输出格式:
输出第1行首先给出达到最低分数线的考生人数M,随后M行,每行按照输入格式输出一位考生的信息,考生按输入中说明的规则从高到低排序。当某类考生中有多人总分相同时,按其德分降序排列;若德分也并列,则按准考证号的升序输出。
输入样例:

14 60 80
10000001 64 90
10000002 90 60
10000011 85 80
10000003 85 80
10000004 80 85
10000005 82 77
10000006 83 76
10000007 90 78
10000008 75 79
10000009 59 90
10000010 88 45
10000012 80 100
10000013 90 99
10000014 66 60

输出样例:

12
10000013 90 99
10000012 80 100
10000003 85 80
10000011 85 80
10000004 80 85
10000007 90 78
10000006 83 76
10000005 82 77
10000002 90 60
10000014 66 60
10000008 75 79
10000001 64 90

分析

说白了就是分成四类,然后排序输出,但是这道题最麻烦的一点,

当某类考生中有多人总分相同时,按其德分降序排列;若德分也并列,则按准考证号的升序输出

这个???怎么实现,最开始可能你和我一样,想的是常规排序里实现,比如冒泡,当总分相等时开始记录,然后再在总分相等的里面按得分排序,然后如果得分相等,再按准考证号的升序排序…仔细想一想多少个for了 ?
我们借助C++里 algorithm 头文件自带的 sort 函数实现排序
sort()函数实现给定区间内元素排序,使用的排序方法类似快排,所以执行效率高
其函数原型为

sort(start,end,compare)
start 是排序开始地址,end 是排序结束地址,compare 是排序方法,compare 可省,默认为升序 排列

比如

int a[10]={9,6,3,8,5,2,7,4,1,0};
sort(a,a+10);

排序后结果是:

0 1 2 3 4 5 6 7 8 9

如果要实现从大到小排序,那么 compare 就派上用场了,我们需要在主函数外面构造一个 compare函数

bool compare(int a,int b){  
    return a>b;
}

现在再进行

int a[10]={9,6,3,8,5,2,7,4,1,0};
sort(a,a+10,compare);

输出结果为:

9 8 7 6 5 4 3 2 1 0

借助这个函数,我们可以写出代码,说出来你们可能不信,cincout超时,要换成scanfprintf

代码(cpp)

#include<iostream>
#include<algorithm>
using namespace std;
int n,l,h;
struct student{
    int num;
    int cai;
    int de;
};
struct student stu1[100000+5];
struct student stu2[100000+5];
struct student stu3[100000+5];
struct student stu4[100000+5];
bool com(struct student a,struct student b){
    if(a.de + a.cai  != b.de + b.cai)   //当德才总分不想等
        return (a.de+a.cai) > (b.de+b.cai);   //按总分降序排列
    else   //当德才总分相等
        if(a.de == b.de)   //当得分相等
            return a.num < b.num;   //按准考证升序排列
        else   //当得分不想等
            return a.de > b.de;  //按得分降序排列
}
int main(){
    int k=0;
    int s1,s2,s3,s4;
    s1=s2=s3=s4=0;
    cin>>n>>l>>h;
    for(int i=0;i<n;i++){
        int num,de,cai;
        cin>>num>>de>>cai;
        if(de >= l && cai >= l){
            if(de>=h && cai >=h){
                stu1[s1].num = num;
                stu1[s1].de = de;
                stu1[s1].cai = cai;
                s1++;
            }
            else if(de>=h && cai <h){
                stu2[s2].num = num;
                stu2[s2].de = de;
                stu2[s2].cai = cai;
                s2++;
            }
            else if(de<h && cai<h && de>=cai){
                stu3[s3].num = num;
                stu3[s3].de = de;
                stu3[s3].cai = cai;
                s3++;
            }
            else{
                stu4[s4].num = num;
                stu4[s4].de = de;
                stu4[s4].cai = cai;
                s4++;
            }
        }
    }
    sort(stu1,stu1+s1,com);
    sort(stu2,stu2+s2,com);
    sort(stu3,stu3+s3,com);
    sort(stu4,stu4+s4,com);
    cout<<s1+s2+s3+s4<<endl;
    for(int i=0;i<s1;i++)
        printf("%d %d %d\n",stu1[i].num,stu1[i].de,stu1[i].cai);
    for(int i=0;i<s2;i++)
        printf("%d %d %d\n",stu2[i].num,stu2[i].de,stu2[i].cai);
    for(int i=0;i<s3;i++)
        printf("%d %d %d\n",stu3[i].num,stu3[i].de,stu3[i].cai);
    for(int i=0;i<s4;i++)
        printf("%d %d %d\n",stu4[i].num,stu4[i].de,stu4[i].cai);
    return 0;
}