题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1299
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

Diophantus of Alexandria was an egypt mathematician living in Alexandria. He was one of the first mathematicians to study equations where variables were restricted to integral values. In honor of him, these equations are commonly called diophantine equations. One of the most famous diophantine equation is x^n + y^n = z^n. Fermat suggested that for n > 2, there are no solutions with positive integral values for x, y and z. A proof of this theorem (called Fermat's last theorem) was found only recently by Andrew Wiles.

Consider the following diophantine equation: 

1 / x + 1 / y = 1 / n where x, y, n ∈ N+ (1)

Diophantus is interested in the following question: for a given n, how many distinct solutions (i. e., solutions satisfying x ≤ y) does equation (1) have? For example, for n = 4, there are exactly three distinct solutions: 

1 / 5 + 1 / 20 = 1 / 4
1 / 6 + 1 / 12 = 1 / 4
1 / 8 + 1 / 8 = 1 / 4

Clearly, enumerating these solutions can become tedious for bigger values of n. Can you help Diophantus compute the number of distinct solutions for big values of n quickly?

Input

The first line contains the number of scenarios. Each scenario consists of one line containing a single number n (1 ≤ n ≤ 10^9). 

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Next, print a single line with the number of distinct solutions of equation (1) for the given value of n. Terminate each scenario with a blank line. 

Sample Input

2
4
1260

Sample Output

Scenario #1:
3

Scenario #2:
113

Problem solving report:

Description: 给我们一个整数,要求算出这个整数的倒数可以分成两个整数倒数和的个数有多少.
Problem solving: 定理1: 一个正整数 n 可以用素因子唯一表示为 p1^r1 * p2^r2 * ... pk^rk (其中 pi 为素数) , 那么这个数的因子的个数就是,(r1+1)*(r2+1)~(rk+1).

定理2:如果一个数字 n = p1^r1 * p2^r2 * ··· * pk^rk ,那么 n*n = p1^r1 * p2^r2 * ··· * pk^rk *  p1^r1 * p2^r2 * ··· * pk^rk ,它的因子的个数就是 (2*r1+1)*(2*r2+1)*···*(2*rk+1).

假设y=n+k 则 x=n*(n+k)/k -> x=n^2/k+n,因子数就是num=(1+r1)*(1+r2)*(1+r3)···
n*n的因子数就是num=(1+2*r1)*(1+2*r2)*(1+2*r3)···

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
const int MAXM = 5e4 + 5;
bool isprime[MAXM];
int cnt = 0, pre[MAXM], vis[MAXM];
void prime() {
    isprime[0] = isprime[1] = true;
    for (int i = 2; i < MAXM; i++) {
        if (!isprime[i])
            pre[cnt++] = i;
        for (int j = 0; j < cnt && i * pre[j] < MAXM; j++) {
            isprime[i *pre[j]] = true;
            if (!(i % pre[j]))
                break;
        }
    }
}
long long slove(int n) {
    long long ans = 1, res;
    for (int i = 0; i < cnt && n != 1; i++) {
        res = 0;
        while (!(n % pre[i])) {
            res++;
            n /= pre[i];
        }
        ans *= res << 1 | 1;
    }
    if (n != 1)//本身是素数
        ans *= 3;//ans *= 1 << 1 | 1;
    return ans;
}
int main() {
    prime();
    int n, t;
    scanf("%d", &t);
    for (int i = 1; i <= t; i++) {
        scanf("%d", &n);
        printf("Scenario #%d:\n%lld\n\n", i, (slove(n) + 1) >> 1);
    }
    return 0;
}