Six Degrees of Cowvin Bacon

Time Limit: 1000MS Memory Limit: 65536K

Description

The cows have been making movies lately, so they are ready to play a variant of the famous game “Six Degrees of Kevin Bacon”.

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one ‘degree’ away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two ‘degrees’ away from each other (counted as: one degree to the cow they’ve worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.

Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.

Output

  • Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.

Sample Input

4 2
3 1 2 3
2 3 4

Sample Output

100
Hint

[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 – a mean of 1.00 .]

思路:

题目问的全部牛中的平均度最低,全部的话明显使用floyd算法,这样比较方便,然后就是套用floyd的模板就行了。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn = 310;
const int inf = 0x3f3f3f3f;
int map[maxn][maxn] = {0};
int a[maxn] = {0};
int main() {
    int n, m, t;
    scanf("%d %d", &n, &m);
    memset(map, inf, sizeof(map));
    for (int i = 0; i < m; i++) {
        scanf("%d", &t);
        for (int j = 0; j < t; j++) scanf("%d", &a[j]);
        for (int j = 0; j < t; j++) {
            for (int k = j + 1; k < t; k++) {
                map[a[j]][a[k]] = map[a[k]][a[j]] = 1;
            }
        }
    }
    for (int i = 1; i <= n; i++) {
        for (int j = 1; j <= n; j++) {
            for (int k = 1; k <= n; k++) {
                if (i != j) {
                    map[i][j] = min(map[i][k] + map[k][j], map[i][j]);
                }
            }
        }
    }
    double Min = inf;
    for (int i = 1; i <= n; i++) {
        double sum = 0;
        int cnt = 0;
        for (int j = 1; j <= n; j++) {
            if (i != j && map[i][j] != inf) {
                sum += map[i][j];
            }
        }
        Min = min(Min, sum / (n - 1));
    }
    int x = Min * 100;
    printf("%d\n", x);
    return 0;
}