L2-012 关于堆的判断 (25分)

看了柳神的题解才意识到题目要求一个一个插入。所以要边插入边建堆,如果是插入完成后调整堆会爆1 和3测试点。

7-38 关于堆的判断

将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出T,否则输出F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T
#include<iostream>
#include<vector> 
using namespace std;
vector<int>v;
int main(){
	int a,b;
	cin>>a>>b;
	v.resize(a+1);
	for(int d=1;d<=a;d++){
        int i=d;
		cin>>v[i];
     	while(i != 1&&v[i] < v[i / 2]) {
           	swap(v[i], v[i / 2]);
           	i = i / 2;
     	}
    }
	for(int i=0;i<b;i++){
		int c,d,j;
		string s;
		cin>>c>>s;
		if(s=="and"){
			cin>>d>>s>>s;
			if(c>d){swap(c,d);}
                int l;
				for(j=0;v[j]!=c;j++);
                for(l=0;v[l]!=d;l++);
				if(j/2 == l/2)cout<<"T"<<endl;
				else cout<<"F"<<endl;
			
		}else{
			cin>>s;
			if(s=="a"){
				cin>>s>>s>>d;
				for(j=0;v[j]!=c;j++);
				if(v[j/2]==d)cout<<"T"<<endl;
				else cout<<"F"<<endl;
			}else{
				cin>>s;
				if(s=="root"){
					if(v[1]==c)cout<<"T"<<endl;
					else cout<<"F"<<endl;
				}else{
					cin>>s>>d;
					for(j=0;v[j]!=d;j++);
					if(v[j/2]==c)cout<<"T"<<endl;
					else cout<<"F"<<endl;
				}
			}
		}
	}
	return 0;
}