Highways

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length.

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built.

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of ith town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location.

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway.

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space.

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty.

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3

题意描述:
已知有n个城镇及它们的坐标,且已有m个条路已经修通,输出若使所有的城镇连接起来并且使所修公路的距离最短需要修建哪些公路。

解题思路:

求最小生成树的所走路径,在网上看了题解,两种方法Kruskal算法和prim算法;kruskal算法先把每两个个城镇间的距离存储,再先将已修建的路连接起来,连接的路赋给一个祖先,再将所有的路进行排序后,查找,所有城镇连通后输出不是一个祖先连接的公路;prim算法先将各个城镇的距离求出来,当两个城镇已经相连时距离更新为0,,另开一个数组p存储哪两条公路相连了当更新dis数组时p数组也更新与之相连的公路,最后找到了所有相连的公路,输出距离不为0的两个城镇既是新修建的公路。

Kruskal:

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct A
{
	int a;
	int b;
	double c;
}q[1000010];
double cmp(struct A x,struct A y)
{
	return x.c<y.c;
}
int f[10010],a[10010],b[10010];
int getf(int i)
{
	if(f[i]==i)
		return i;
	else
	{
		f[i]=getf(f[i]);
		return f[i];
	}
}
int merge(int v,int u)
{
	int t1,t2;
	t1=getf(u);
	t2=getf(v);
	if(t1!=t2)
	{
		f[t1]=t2;
		return 1;
	}
	return 0;
}

int main()
{
	int n,m,x,y,i,j,v,t,cut;
	scanf("%d",&n);
		for(i=1;i<=n;i++)
			scanf("%d%d",&a[i],&b[i]);
		v=1;
		for(i=1;i<n;i++)//存储路径 
			for(j=i+1;j<=n;j++)
			{
				q[v].a=i;
				q[v].b=j;
				q[v].c=(double)sqrt((a[i]-a[j])*(a[i]-a[j])+(b[i]-b[j])*(b[i]-b[j]));
				v++;
			}
		v=v-1;
		sort(q+1,q+v+1,cmp);
		for(i=1;i<=n;i++)
			f[i]=i;
		scanf("%d",&m);
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&x,&y);
			merge(x,y);//查找是否为共同祖先,赋给共同祖先 
		}
		cut=0;
		for(i=1;i<=v;i++)
		{
			if(merge(q[i].a,q[i].b))//若不是一个共同祖先说明两城镇间未连接为需要建设的城镇 
			{						//存储两城镇 
				a[cut]=q[i].a;
				b[cut]=q[i].b;
				cut++;
			}
			if(cut==n-1)//这个判断只是为了提前结束循环,不加也能AC 
				break;
		}
		for(i=0;i<cut;i++)
			printf("%d %d\n",a[i],b[i]);
	return 0;
}

Prim:

#include<stdio.h>
#include<string.h>
#include<math.h> 
# define inf 0x7f7f7f7f
int book[1010],a[1010],b[1010],p[1010];
double  map[1010][1010],dis[1010];
int main()
{
	int n,m,i,j,u,v,x,y,k;
	double sum,min;
	while(scanf("%d",&n)!=EOF)
	{
		for(i=1;i<=n;i++)
			scanf("%d%d",&a[i],&b[i]);
		memset(map,0,sizeof(map));
		
		for(i=1;i<n;i++)//存储两城镇间距离到map数组 
			for(j=i+1;j<=n;j++)
			{
				map[i][j]=(double)sqrt((a[i]-a[j])*(a[i]-a[j])+(b[i]-b[j])*(b[i]-b[j]));
				map[j][i]=map[i][j];
			}
		scanf("%d",&m); 
		for(i=1;i<=m;i++)//城镇间已有公路距离为0 
		{
			scanf("%d%d",&x,&y);
			map[x][y]=0;
			map[y][x]=0;
		}
		memset(book,0,sizeof(book));
		for(i=1;i<=n;i++)
		{
			dis[i]=map[1][i];
			p[i]=1;//假设所有城镇都是与1号城镇连接最优;其实和dis数组一个意思,后面也一样更新 
		}
		book[1]=1;
		for(i=1;i<n;i++)
		{
			min=inf;
			for(j=1;j<=n;j++)
			{
				if(book[j]==0&&dis[j]<min)
				{
					min=dis[j];
					u=j;
				}
			}
			book[u]=1;
			for(v=1;v<=n;v++)
			{
				if(book[v]==0&&dis[v]>map[u][v])
				{
					dis[v]=map[u][v];//当有更优的路线到v城镇更新距离,更新与v城镇相连的城镇号 
					p[v]=u;
				}
			}
		}
		for(i=1;i<=n;i++)
			if(map[i][p[i]]!=0)//输出所有距离不为0相连的城镇即为需要建设的道路 
			printf("%d %d\n",p[i],i);
	}
	return 0;
}