题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1649
Time Limit: 2 Seconds Memory Limit: 65536 KB

Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.
Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.
You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.
Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.
Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8
#.#####. 
#.a#..r. 
#..#x... 
..#..#.# 
#...##.. 
.#...... 
........

Sample Output

13

Problem solving report:

Description: 牢房里有墙(#),警卫(x)和道路(.),天使被关在牢房里位置为a,你的位置在r处,杀死一个警卫要一秒钟,每走一步要一秒钟,求最短时间救出天使,不能救出则输出:Poor ANGEL has to stay in the prison all his life.
Problem solving: BFS搜索,利用vis[x][y]保存到(x,y)的最短距离,剪枝一下。

#include <queue>
#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
struct edge {
    int x, y;
}p;
char map[205][205];
const int inf = 99999;
int n, m, vis[205][205];
int dir[4][2] = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}};
bool Judge(int x, int y) {
    return (x >= 0 && x < n && y >= 0 && y < m && map[x][y] != '#');
}
void BFS(edge e) {
    int tx, ty, t;
    queue <edge> Q;
    Q.push(e);
    vis[e.x][e.y] = 0;
    while (!Q.empty()) {
        p = Q.front();
        Q.pop();
        for (int i = 0; i < 4; i++) {
            tx = p.x + dir[i][0];
            ty = p.y + dir[i][1];
            if (Judge(tx, ty)) {
                t = 1;
                if (map[p.x][p.y] == 'x')
                    t++;
                t += vis[p.x][p.y];
                if (t < vis[tx][ty]) {
                    vis[tx][ty] = t;
                    Q.push((edge){tx, ty});
                }
            }
        }
    }
}
int main() {
    struct edge e, s;
    while (~scanf("%d%d", &n, &m)) {
        for (int i = 0; i < n; i++) {
            for (int j = 0; j < m; j++) {
                vis[i][j] = inf;
                scanf(" %c", &map[i][j]);
                if (map[i][j] == 'r')
                    e = (edge){i, j};
                else if (map[i][j] == 'a')
                    s = (edge){i, j};
            }
        }
        BFS(e);
        if (vis[s.x][s.y] < inf)
            printf("%d\n", vis[s.x][s.y]);
        else printf("Poor ANGEL has to stay in the prison all his life.\n");
    }
    return 0;
}