|
过山车Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 27200 Accepted Submission(s): 11731 Problem Description RPG girls今天和大家一起去游乐场玩,终于可以坐上梦寐以求的过山车了。可是,过山车的每一排只有两个座位,而且还有条不成文的规矩,就是每个女生必须找个个男生做partner和她同坐。但是,每个女孩都有各自的想法,举个例子把,Rabbit只愿意和XHD或PQK做partner,Grass只愿意和linle或LL做partner,PrincessSnow愿意和水域浪子或伪酷儿做partner。考虑到经费问题,boss刘决定只让找到partner的人去坐过山车,其他的人,嘿嘿,就站在下面看着吧。聪明的Acmer,你可以帮忙算算最多有多少对组合可以坐上过山车吗? Input 输入数据的第一行是三个整数K , M , N,分别表示可能的组合数目,女生的人数,男生的人数。0<K<=1000 1<=N 和M<=500.接下来的K行,每行有两个数,分别表示女生Ai愿意和男生Bj做partner。最后一个0结束输入。 Output 对于每组数据,输出一个整数,表示可以坐上过山车的最多组合数。 Sample Input 6 3 3 1 1 1 2 1 3 2 1 2 3 3 1 0 Sample Output 3 Author PrincessSnow Source Recommend |
这道题就是一道二分图匹配的裸题,如果不清楚二分图就欢迎看我的上一篇文章~~不过很奇怪的是竟然是女生选男生~~很是诧异。
#include<cstdio>
#include<iostream>
using namespace std;
bool map[1005][1005];
int boy[1005];
bool use[1005];
int ans = 0;
int g, b;
void init()
{
memset(map, 0, sizeof(map));
memset(boy, 0, sizeof(boy));
memset(use, 0, sizeof(use));
ans = 0;
}
int find(int x)
{
for (int s = 1; s <= b; s++)
{
if (map[x][s] && !use[s])
{
use[s] = 1;
if (!boy[s] || find(boy[s]))
{
boy[s] = x;
return 1;
}
}
}
return 0;
}
int main()
{
int k;
while (~scanf("%d", &k) && k)
{
init();
scanf("%d %d", &g, &b);
while (k--)
{
int a, b;
scanf("%d %d", &a, &b);
map[a][b] = 1;
}
for (int s = 1; s <= g; s++)
{
memset(use, 0, sizeof(use));
if (find(s))
{
ans++;
}
}
cout << ans << endl;
}
return 0;
}