Harmonic Value Description

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 105    Accepted Submission(s): 75
Special Judge


Problem Description
The harmonic value of the permutation p1,p2,pn is
i=1n1gcd(pi.pi+1)

Mr. Frog is wondering about the permutation whose harmonic value is the strictly k-th smallest among all the permutations of [n].
 

Input
The first line contains only one integer T ( 1T100), which indicates the number of test cases.

For each test case, there is only one line describing the given integers n and k ( 12kn10000).
 

Output
For each test case, output one line “Case #x: p1 p2  pn”, where x is the case number (starting from 1) and p1 p2  pn is the answer.
 

Sample Input
2 4 1 4 2
 

Sample Output
Case #1: 4 1 3 2 Case #2: 2 4 1 3
 

Source


思路:
题意表面上是让你求相邻两个数的gcd的和的第k小值,实际上跟gcd一点关系没有。。gcd最小的话就按照123456这样排的话就是最小的,相邻的数肯定互质。然后求第k小,也就是k和2k相邻,其他的相邻的还是互质。所以就直接只需要将2K和K提出来,将2K放在开头,K放在第二个,接下来只要满足相邻两个数仍然相差1即可。只要将K-1~1接在K后面,把K+1~2N接在1后面,去掉2K即可。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <string>
#include <queue>
#include <algorithm>

using namespace std;

int main()
{
    int T,n,k;
    scanf("%d",&T);
    for (int t=1;t<=T;t++) {
        scanf("%d%d",&n,&k);
        printf("Case #%d: ",t);
        if (k==1) {
            for (int i=1;i<=n;i++)
                printf("%d%c",i,i==n?'\n':' ');
        } else {
            for (int i=2*k-1;i>=1;i-=2)
                printf("%d ",i);
            for (int i=2;i<=2*k;i+=2)
                printf("%d%c",i,(i==n)?'\n':' ');
            for (int i=2*k+1;i<=n;i++)
                printf("%d%c",i,(i==n)?'\n':' ');
        }
    }
    return 0;
}