An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window position Minimum value Maximum value
[1 3 -1] -3 5 3 6 7 -1 3
1 [3 -1 -3] 5 3 6 7 -3 3
1 3 [-1 -3 5] 3 6 7 -3 5
1 3 -1 [-3 5 3] 6 7 -3 5
1 3 -1 -3 [5 3 6] 7 3 6
1 3 -1 -3 5 [3 6 7] 3 7
Your task is to determine the maximum and minimum values in the sliding window at each position.

Input
The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.
Output
There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.
Sample Input
8 3
1 3 -1 -3 5 3 6 7
Sample Output
-1 -3 -3 -3 3 3
3 3 5 5 6 7
https://vjudge.net/contest/418293#problem/B

解:滑窗问题,虽然可恶的学长建议使用c++stl中的deque(前后都能进出,相当于栈和队列的融合版)来做题,但是因为本题有区间限制,最大最小值有可能会离开区间。
对于这种情况,只能用一个数组来记录下标,解题才较为方便,清晰。此外,这个数组记录的是一个单调队列的下标du[,要最大值就是第一个值

#include <iostream>
#include <deque>
#include <algorithm>
#include <math.h>
using namespace std;
const int N = 1000010;
int lst[N];//读数据
int du[N];//单调队列的下标
int main()
{
    int n,k;
    scanf("%d%d", &n, &k);

        for (int i = 1; i < n + 1; i++)
            scanf("%d", &lst[i]);
        int l = 1, r = 2;//左右边界
        du[1] = 1;//初始化
        if (k == 1)//特殊情况,不写缺一个数字
            printf("%d ",lst[1]);
        for (int i = 2; i <= n; i++)
        {
            if (i - du[l] + 1 > k && l < r)
                l++;//最左数字寿命到了,踢出去
            while (lst[i] < lst[du[r - 1]] && l <r)
                r--;//干掉单调队列中比lst[i]大的数字
            du[r] = i;//记录下标
            ++r;//向右一个单位
            if (i >= k)
                printf("%d ", lst[du[l]]);
        }       
        printf("\n");

        l = 1, r = 2;
        if (k == 1)
            printf("%d ", lst[1]);
        du[1] = 1;
        for (int i = 2; i <= n; i++)
        {        

            if (i - du[l] + 1 > k && l < r) l++;
            while (l<r && lst[du[r - 1]] < lst[i]) r--;
            du[r] = i;
            ++r;
            if (i >= k)
                printf("%d ", lst[du[l]]);
        }        

    return 0;
}