Candy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2705    Accepted Submission(s): 1199
Special Judge


Problem Description
LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?
 

Input
There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 105) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10-4 would be accepted.
 

Sample Input
  
  
10 0.400000 100 0.500000 124 0.432650 325 0.325100 532 0.487520 2276 0.720000
 

Sample Output
  
  
Case 1: 3.528175 Case 2: 10.326044 Case 3: 28.861945 Case 4: 167.965476 Case 5: 32.601816 Case 6: 1390.500000

Candy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2705    Accepted Submission(s): 1199
Special Judge


Problem Description
LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?
 

Input
There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 105) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10-4 would be accepted.
 

Sample Input
  
  
10 0.400000 100 0.500000 124 0.432650 325 0.325100 532 0.487520 2276 0.720000
 

Sample Output
  
  
Case 1: 3.528175 Case 2: 10.326044 Case 3: 28.861945 Case 4: 167.965476 Case 5: 32.601816 Case 6: 1390.500000
这题是数学期望的题,主要是求排列组合的时候会爆掉,所以要用快速排列组;
预定义一个f数组
for(in i=1;i<N;i++)
f[i]=f[i-1]+log(1.0*i);
f数组存放的是log1乘到i;
所以C(n,m)=f[n]-f[m]-f[n-m];
贴下ac代码
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
const int N=2e5+5;
double v1[N],v2[N];
typedef long long ll;
double f[N];
double logc(ll m,ll n)
{
    return f[m]-f[n]-f[m-n];
}
int main()
{
    int n,cas=0;
    double p;
    f[0]=0;
    //freopen("input.txt","r",stdin);
    for(int i=1;i<N;i++)
        f[i]=f[i-1]+log(i*1.0);
    while(~scanf("%d%lf",&n,&p))
    {
        double ans=0;ll i=0;
        for(ll i=0;i<=n;i++)
        {
            v1[i]=logc(2*n-i,n)+1.0*(n+1)*log(p)+1.0*(n-i)*log(1-p);
            v2[i]=logc(2*n-i,n)+(n+1)*log(1-p)+(n-i)*log(p);
            ans+=1.0*i*(1.0*exp(v1[i])+1.0*exp(v2[i]));
        }
        printf("Case %d: %.6lf\n",++cas,ans);
    }
    return 0;
}