hide handkerchief

Problem Description
The Children’s Day has passed for some days .Has you remembered something happened at your childhood? I remembered I often played a game called hide handkerchief with my friends.
Now I introduce the game to you. Suppose there are N people played the game ,who sit on the ground forming a circle ,everyone owns a box behind them .Also there is a beautiful handkerchief hid in a box which is one of the boxes .
Then Haha(a friend of mine) is called to find the handkerchief. But he has a strange habit. Each time he will search the next box which is separated by M-1 boxes from the current box. For example, there are three boxes named A,B,C, and now Haha is at place of A. now he decide the M if equal to 2, so he will search A first, then he will search the C box, for C is separated by 2-1 = 1 box B from the current box A . Then he will search the box B ,then he will search the box A.
So after three times he establishes that he can find the beautiful handkerchief. Now I will give you N and M, can you tell me that Haha is able to find the handkerchief or not. If he can, you should tell me "YES", else tell me "POOR Haha".

Input
There will be several test cases; each case input contains two integers N and M, which satisfy the relationship: 1<=M<=100000000 and 3<=N<=100000000. When N=-1 and M=-1 means the end of input case, and you should not process the data.

Output
For each input case, you should only the result that Haha can find the handkerchief or not.

Sample Input
3 2
-1 -1

Sample Output
YES

Source
HDU 2007-6 Programming Contest

Recommend
xhd

正确代码

#include <cstdio>  
    #include <iostream>  
    using namespace std;  
    int gcd(int a,int b)  
    {  
        int c=a%b;  
        return c==0?b:gcd(b,c);  
    }  
    int main()  
    {  
        long long n,m;  
        while(cin>>n>>m)  
        {  
            if(n==-1&&m==-1)  
                break;  
            if(gcd(n,m)==1)  
                cout<<"YES"<<endl;  
            else  
                cout<<"POOR Haha"<<endl;  
        }  
    }

题意理解
较为简单的遍历算法题,问题的关键在于怎么判断不断跳过m-1次盒子是否可以遍历到所有n个盒子。当盒子的数量n与跳过盒子的数量m-1互为质数时,则能遍历所有盒子,若n与m-1有除1以外其他最大公约数时,haha就会回到起点重复之前的动作从而导致无法遍历所有盒子。