1002. A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 … NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, …, K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < … < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output

3 2 1.5 1 2.9 0 3.2

程序代码:

#include<stdio.h>
#include<math.h>
#define EPSION 0.1
double a[1001]={0};
int main()
{
    int k;
    scanf("%d",&k);
    int i;
    double c;
    int e;
    for(i=0;i<k;i++)
    {
        scanf("%d%lf",&e,&c);
        a[e]=c;     
    }
    scanf("%d",&k);
    for(i=0;i<k;i++)
    {
        scanf("%d%lf",&e,&c);
        a[e]+=c;
    }
    int count = 0;
    for(i=1000;i>=0;i--)
    {
        if(fabs(a[i])>=EPSION)
            count++;
    }
    if(count == 0)
    {
        printf("0");
        return 0;
    }
    printf("%d ",count);
    for(i=1000;i>=0;i--)
    {
        if(fabs(a[i])>=EPSION)
        {
            printf("%d %.1f",i,a[i]);
            count--;
            if(count>0)
                putchar(' ');
        }
    }   
    return 0;
}