Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject's name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject's homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.

Output

For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.

Sample Input

2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3

Sample Output

2
Computer
Math
English
3
Computer
English
Math


        
  

Hint

In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the 
word "English" appears earlier than the word "Math", so we choose the first order. That is so-called alphabet order.

        

题意:

有 n 门科目的作业,给出每门作业的deadline和完成作业需要花的时间,延迟一天将要扣1分,问完成作业的顺序使得扣分最少。

https://blog.csdn.net/xingyeyongheng/article/details/21742341

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int mod = 1e9 + 7;
const int N = (1 << 15) + 10;

int dp[N], t[N], ddl[N], pre[N], cost[N];
string s[20];

void output(int id)
{
    if(!id)
        return ;
    output(id - (1 << pre[id]));
    cout<<s[pre[id]]<<'\n';
}

int main()
{
    int n, T;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        for(int i = 0; i < n; ++i)
        {
            cin >> s[i] >> ddl[i] >> cost[i];
        }
        int bit = 1 << n;
        for(int i = 1; i < bit; ++i)
        {
            dp[i] = inf;
            for(int j = n - 1; j >= 0; --j)
            {
                int tmp = (1 << j);
                if(!(i & tmp))///i不包含tmp
                    continue;
                int score = t[i - tmp] + cost[j] - ddl[j];
                if(score < 0)
                    score = 0;
                if(dp[i] > dp[i - tmp] + score)
                {
                    dp[i] = dp[i - tmp] + score;
                    t[i] = t[i - tmp] + cost[j];
                    pre[i] = j;
                }
            }
        }
        cout<<dp[bit - 1]<<'\n';
        output(bit - 1);
    }
    return 0;
}