Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!
Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.
Input Specification:
Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.
Output Specification:
For each test case, first print in a line “Yes” if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or “No” if not. Then in the next line, print the doubled number.
Sample Input:
1234567899
Sample Output:
Yes
2469135798
程序代码:
#include<stdio.h>
#include<string.h>
char a[21]={0};
char b[21]={0};
int count[10]={0};
int main()
{
scanf("%s",a);
int i,tmp=0, len = strlen(a)-1;
for(i=len;i>=0;i--)
{
count[a[i]-'0']++;
b[i]=(tmp+(a[i]-'0')*2)%10+'0';
tmp =((tmp+(a[i]-'0')*2))/10;
}
if(tmp>0)
{
printf("No\n");
printf("1%s",b);
}
else
{
for(i=len;i>=0;i--)
{
count[b[i]-'0']--;
}
for(i=0;i<=9;i++)
{
if(count[i]!=0)
{
printf("No\n%s",b);
return 0;
}
}
printf("Yes\n%s",b);
}
return 0;
}