Moving Tables

Problem Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50


Sample Output

10

20

30

题意描述:

有400个房间,如图1排列,一直走廊只能放下一张桌子,一张桌子从一个房间移动到另一个房间需要10分钟。当移动桌子不共用一个走廊时可以同时进行移动,来减少用时,当走廊冲突时,要分开来移动。给出n个移动,求出最少用时。

解题思路:

由图1可知,(1,2),(3,4),(5,6)……每一组为一个走廊,将房间号加1除2,即为走廊号,根据房间号,求出需要使用的走廊号。走廊使用一次对应次数加一,最后求出走廊的最大使用次数乘10即为所求的最少用时。

错误分析:

刚看到这道题一直想到的是用数组,找最后房间号排序,当走廊冲突时再相加时间,WA了好多次,看了题解发现思路错了。这道题还要注意下先输入的房间号的大小不一定。

程序代码:

#include<stdio.h>
#include<string.h>
int main()
{
	int t,num,n,i,s,x,y,q[250],j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		memset(q,0,sizeof(q));
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&x,&y);
			x=(x+1)/2;
			y=(y+1)/2;
			if(x>y)
			{
				s=x;
				x=y;
				y=s;
			}
			for(j=x;j<=y;j++)
				q[j]++;
		}
		s=0;
		for(i=1;i<=210;i++)
		{
			if(q[i]>s)
				s=q[i];
		}
		printf("%d\n",s*10);
	}
	return 0;
}