题目:

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter <tt>'e'</tt>. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive <tt>'T'</tt>s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {<tt>'A'</tt>, <tt>'B'</tt>, <tt>'C'</tt>, …, <tt>'Z'</tt>} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

  • One line with the word W, a string over {<tt>'A'</tt>, <tt>'B'</tt>, <tt>'C'</tt>, …, <tt>'Z'</tt>}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
  • One line with the text T, a string over {<tt>'A'</tt>, <tt>'B'</tt>, <tt>'C'</tt>, …, <tt>'Z'</tt>}, with |W| ≤ |T| ≤ 1,000,000.
Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0

给定两个字符串a,b,求字符串a在b中出现的最大次数(b由多个a重叠拼接或者直接首尾相接而成)


用KMP中的next数组记录,每记录一次count++最后输出count即可

AC代码(c++):

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
#define N 100010
char s[1000010], p[N];
int next[N];
int lens, lenp;
int KMP()
{
	int i=0,j=0,count=0;
	while(i!=lens&&j!=lenp)
	{
		if(s[i]==p[j]||j==-1)
        {
            i++;
            j++;
        }
		else
			j=next[j];
		if(j==lenp)
		{
			count++;
			j=next[j];
		}
	}
	return count;
}
int main()
{
	int n;
	int len;
	int ans;
	scanf("%d", &n);
	while(n--)
	{
		scanf("%s %s", p, s);
		lens = strlen(s);
		lenp = strlen(p);
		int i=0,j=-1;
        next[0]=-1;
        while(i<lenp)
        {
            if(j==-1||s[i]==s[j])
            {
                i++;
                j++;
                next[i]=j;
            }
            else
                j=next[j];
        }
		ans=KMP();
		printf("%d\n", ans);
	}
	return 0;
}