Cyclic Nacklace

Problem Description

CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of "HDU CakeMan", he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl's fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls' lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet's cycle is 9 and its cyclic count is 2:


Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.
CC is satisfied with his ideas and ask you for help.

Input

The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.
Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by 'a' ~'z' characters. The length of the string Len: ( 3 <= Len <= 100000 ).

Output

For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.

Sample Input

3

aaa

abca

abcde

Sample Output

0

2

5

题意描述:

求一个字符串可以通过加上最少的字节使它成为一个至少循环两次的字符串,输出最少字节数。

解题思路:

求出next[]数组,得到字符串每个位置的最大前缀,通过最后一个字节的next[]值的多少及字符长度的大小得出结果。

●字符串长度减去next[]最后字节值为字符串中循环节的长度。

  1. 当next[]最后字节值为0是说明在前面无发生循环,加字符串长度的字节形成循环。
  2. 当字符串长度是循环节的倍数时,说明字符串刚好是循环的整数倍,无需再添加字节。
  3. 否则就需添加循环节的长度与字符串长度对循环节长度的余数的差值。     
#include<stdio.h>
#include<string.h>
int next[100010],lena;
char a[100010];
void get_next(char a[],int lena)
{
	int i,j;
	j=0;
	i=1;
	while(i<=lena-1)
	{
		if(a[i]==a[j])
		{
			next[i]=j+1;
			i++;
			j++;
		}
		if(j==0&&a[i]!=a[j])
		{
			next[i]=0;
			i++;
		}
		if(j>0&&a[i]!=a[j])
			j=next[j-1];
	}
}
int main()
{
	int t;
	while(scanf("%d\n",&t)!=EOF)
	{
		while(t--)
		{
			gets(a);
			lena=strlen(a);
			get_next(a,lena);
			if(next[lena-1]==0)
				printf("%d\n",lena);// next数组最后值为0,说明前面无循环 
			else
			{
				if(lena%(lena-next[lena-1])==0)//刚好为循环的整数倍 
					printf("0\n");
				else
					printf("%d\n",(lena-next[lena-1])-lena%(lena-next[lena-1]));
			}
		}
	}
	return 0;
}