题目链接:http://poj.org/problem?id=3461
Time Limit: 1000MS Memory Limit: 65536K
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
- One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
- One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN
Sample Output
1
3
0
Problem solving report:
Description: 给定两个串,求串1在串2中出现了几次。
Problem solving: 直接套KMP模板。
Accepted Code:
#include <stdio.h>
#include <string.h>
const int MAXN = 10005;
const int MAXM = 1000005;
int nex[MAXN];
char sa[MAXM], sb[MAXN];
void Next(char str[], int len) {
nex[0] = -1;
int i = 0, j = -1;
while (i < len) {
if (~j && str[i] != str[j])
j = nex[j];
else nex[++i] = ++j;
}
}
int KMP(char sa[], char sb[], int la, int lb) {
Next(sb, lb);
int i = 0, j = 0, cnt = 0;
while (i < la) {
if (~j && sa[i] != sb[j])
j = nex[j];
else i++, j++;
if (j >= lb) {
cnt++;
j = nex[j];
}
}
return cnt;
}
int main() {
int t, la, lb;
scanf("%d", &t);
while (t--) {
scanf("%s%s", sb, sa);
la = strlen(sa);
lb = strlen(sb);
printf("%d\n", KMP(sa, sb, la, lb));
}
return 0;
}