Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.
Notice that the square root operation should be rounded down to integer.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.
Notice that the square root operation should be rounded down to integer.
Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
Sample Input
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
Sample Output
Case #1: 19 7 6
Source
Recommend
题意:成段更新单点值为原来的sqrt,成段询问总和
这个题比上一个题更具有普遍意义,因为上一个题并没有l,r域,全凭题目性质将l,r代入函数参数进行相应操作,而这道题update函数如果那么写根本都运行不了QAQ,之所以不用push_up push_down也是运用到了题意中说开根号,全是1就不用继续了呀
/************
hdu4017
2016.3.7
936MS 5848K 1797 B C++
************/
#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
struct node
{
int l,r;
long long sum;
}num[400005];
int n,m,t;
void build(int l,int r,int i)
{
num[i].l=l;
num[i].r=r;
if(l==r)
{
scanf("%I64d",&num[i].sum);
return;
}
int mid=(l+r)/2;
build(l,mid,i<<1);
build(mid+1,r,i<<1|1);
num[i].sum=num[i<<1].sum+num[i<<1|1].sum;
}
void update(int l,int r,int rt)
{
if(num[rt].sum==(num[rt].r-num[rt].l+1)&&l==num[rt].l&&r==num[rt].r)
return;
if(num[rt].l==num[rt].r)
{
num[rt].sum=(int)sqrt(num[rt].sum*1.0);
return;
}
int mid=(num[rt].l+num[rt].r)/2;
if(r<=mid) update(l,r,rt<<1);
else if(l>mid) update(l,r,rt<<1|1);
else
{
update(l,mid,rt<<1);
update(mid+1,r,rt<<1|1);
}
num[rt].sum=num[rt<<1].sum+num[rt<<1|1].sum;
}
long long query(int l,int r,int rt)
{
if(l==num[rt].l&&r==num[rt].r) return num[rt].sum;
long long ans=0;
int mid=(num[rt].l+num[rt].r)/2;
if(r<=mid) ans+=query(l,r,rt<<1);
else if(l>mid) ans+=query(l,r,rt<<1|1);
else
{
ans+=query(l,mid,rt<<1);
ans+=query(mid+1,r,rt<<1|1);
}
return ans;
}
int main()
{
// freopen("cin.txt","r",stdin);
int cas=1;
while(~scanf("%d",&n))
{
printf("Case #%d:\n",cas++);
build(1,n,1);
scanf("%d",&m);
while(m--)
{
int a,b;
scanf("%d%d%d",&t,&a,&b);
if(a>b) swap(a,b);
if(t==0) update(a,b,1);
else printf("%I64d\n",query(a,b,1));
}
puts("");
}
return 0;
}