题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4585
Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 65535/32768 K (Java/Others)

Problem Description

Shaolin temple is very famous for its Kongfu monks.A lot of young men go to Shaolin temple every year, trying to be a monk there. The master of Shaolin evaluates a young man mainly by his talent on understanding the Buddism scripture, but fighting skill is also taken into account.
When a young man passes all the tests and is declared a new monk of Shaolin, there will be a fight , as a part of the welcome party. Every monk has an unique id and a unique fighting grade, which are all integers. The new monk must fight with a old monk whose fighting grade is closest to his fighting grade. If there are two old monks satisfying that condition, the new monk will take the one whose fighting grade is less than his.
The master is the first monk in Shaolin, his id is 1,and his fighting grade is 1,000,000,000.He just lost the fighting records. But he still remembers who joined Shaolin earlier, who joined later. Please recover the fighting records for him.

Input

There are several test cases.
In each test case:
The first line is a integer n (0 <n <=100,000),meaning the number of monks who joined Shaolin after the master did.(The master is not included).Then n lines follow. Each line has two integer k and g, meaning a monk's id and his fighting grade.( 0<= k ,g<=5,000,000)
The monks are listed by ascending order of jointing time.In other words, monks who joined Shaolin earlier come first.
The input ends with n = 0.

Output

A fight can be described as two ids of the monks who make that fight. For each test case, output all fights by the ascending order of happening time. Each fight in a line. For each fight, print the new monk's id first ,then the old monk's id.

Sample Input

3
2 1
3 3
4 2
0

Sample Output

2 1
3 2
4 2

Problem solving report:

Description: 有N个依次进入少林,每次输出新进和尚和战斗等级与其最接近的旧和尚的ID。ID和战斗等级都是唯一的。
Problem solving: 每次输入一个和尚的信息,然后在map里建立映射, 用lower_bound(gra)寻找第一个大于等于当前加入的和尚所在的迭代器;然后,考虑当前的迭代器的位置,要是第一个,就输出当前迭代器;否则和它前面迭代器分别与刚加入的比较first之间的差值哪个更小,小的输出;要是两差值一样的话,输出前一个迭代器。

Accepted Code:

#include <bits/stdc++.h>
using namespace std;
int main() {
    int n, ids, gra;
    while (scanf("%d", &n), n) {
        map <int, int> spt;
        spt[1000000000] = 1;
        for (int i = 0; i < n; i++) {
            scanf("%d%d", &ids, &gra);
            map <int, int>::iterator itl, itr, it = spt.lower_bound(gra);
            itl = itr = it;
            if (itl != spt.begin())
                itl--;
            if (gra - itl -> first > itr -> first - gra)
                itl = itr;
            printf("%d %d\n", ids, itl -> second);
            spt[gra] = ids;
        }
    }
    return 0;
}