题目

蒜头君快要考托福了,这几天,蒜头君每天早上都起来记英语单词。花椰妹时不时地来考一考蒜头君:花椰妹会询问蒜头君一个单词,如果蒜头君背过这个单词,蒜头君会告诉花椰妹这个单词的意思,不然蒜头君会跟花椰妹说还没有背过。

单词是由连续的大写或者小写字母组成。注意单词中字母大小写是等价的。 比如You和you是一个单词。

输入格式

首先输入一个 <math> <semantics> <mrow> <mi> n </mi> <mo> ( </mo> <mn> 1 </mn> <mo> ≤ </mo> <mi> n </mi> <mo> ≤ </mo> <mn> 100000 </mn> <mo> ) </mo> </mrow> <annotation encoding="application&#47;x&#45;tex"> n(1 \le n \le 100000) </annotation> </semantics> </math>n(1n100000) 表示事件数。接下来 <math> <semantics> <mrow> <mi> n </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> n </annotation> </semantics> </math>n 行,每行表示一个事件。

每个事件输入为一个整数 <math> <semantics> <mrow> <mi> d </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> d </annotation> </semantics> </math>d 和一个单词 <math> <semantics> <mrow> <mi> w </mi> <mi> o </mi> <mi> r </mi> <mi> d </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> word </annotation> </semantics> </math>word(单词长度不大于 <math> <semantics> <mrow> <mn> 20 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> 20 </annotation> </semantics> </math>20),用空格隔开。

如果 <math> <semantics> <mrow> <mi> d </mi> <mo> = </mo> <mn> 0 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> d=0 </annotation> </semantics> </math>d=0,表示蒜头君记住了 <math> <semantics> <mrow> <mi> w </mi> <mi> o </mi> <mi> r </mi> <mi> d </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> word </annotation> </semantics> </math>word 这个单词,如果 <math> <semantics> <mrow> <mi> d </mi> <mo> = </mo> <mn> 1 </mn> </mrow> <annotation encoding="application&#47;x&#45;tex"> d=1 </annotation> </semantics> </math>d=1,表示这是一个 测试,测试蒜头君是否认识单词 <math> <semantics> <mrow> <mi> w </mi> <mi> o </mi> <mi> r </mi> <mi> d </mi> </mrow> <annotation encoding="application&#47;x&#45;tex"> word </annotation> </semantics> </math>word(花椰妹永远不会告诉蒜头君这个单词的意思)。

事件的输入是按照时间先后顺序输入的。

输出格式

对于花椰妹的每次 测试,如果蒜头君认识这个单词,输出一行Yes, 否则输出一行No。

样例输入

5

0 we

0 are

1 family

0 Family

1 Family

样例输出

No

Yes

样例输入

4

1 jisuanke

0 Jisuanke

0 JISUANKE

1 JiSuanKe

样例输出

No

Yes

题解

集合基础应用

#include<iostream>
#include<set>
#include<string>
#include<ctype.h>
using namespace std;
string toLow(string s){
	for(int i=0;i<s.length();i++){	
		s[i] = tolower(s[i]);
	}
	return s;
}
int main(){
	set<string> s;
	int n;
	cin>>n;
	int d;
	string str;
	for(int i=0;i<n;i++){
		cin>>d>>str;
		str = toLow(str);
		if(d){ // test
			if(s.count(str))
				cout<<"Yes"<<endl;
			else
				cout<<"No"<<endl;
		}else
			s.insert(str);
	}
	return 0;
}

返回目录,查看更多