Description
How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 <tt>+</tt> 1/3 <tt>=</tt> 5/6 card lengths. In general you can make n cards overhang by 1/2 <tt>+</tt> 1/3 <tt>+</tt> 1/4 <tt>+</tt> ... <tt>+</tt>1/(n <tt>+</tt> 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n <tt>+</tt> 1). This is illustrated in the figure below.
<center>
Input
Output
Sample Input
1.00
3.71
0.04
5.19
0.00
Sample Output
3 card(s)
61 card(s)
1 card(s)
273 card(s)
题目概述:给出一个浮点数c,求出使得 不等式 1/2 + 1/3 + ... + 1/(n+1) >= c 成立的最小 n。
题目中给出了5.2的上限,所以n数组<= 300即可 这里我是打了个表,发现300的。
O复杂度O(300m)m为询问数
<pre name="code" class="cpp">#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
double a[300] = {0,0.5},c;
int main()
{
int num = 0;
for(int i = 2; i < 300; i ++)
a[i] = a[i - 1] + 1.0/(i + 1); //注意这里1.0否则是错的,他会当成int存成0
while(scanf("%lf",&c) && c)
{
for(int i = 1; i < 300; i ++)
if(a[i] >= c)
{
printf("%d card(s)\n",i);
break;
}
}
return 0;
}