题干:

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 

Output

The output consists of one integer representing the largest number of islands that all lie on one line. 

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

Sample Output

1
2
3
        
Hint
Xiao  Ming  won't  ask  Xiao  Bao  the  kth  great  number  when  the  number  of  the  written number is smaller than k. (1=<k<=n<=1000000).
        

题目大意:

根据输入的以上的数据要找到第k大的数。

解题报告:

   优先队列水过去。以后再用线段树?

AC代码:(优先队列)

#include<bits/stdc++.h>
using namespace std;
priority_queue<int,vector<int >, greater<int> > pq;
int main()
{
	int q,k,tmp;
	char op[5];
	while(~scanf("%d%d",&q,&k) ) {
		while(!pq.empty() ) pq.pop();
		while(q--) {
			scanf("%s",op);
			if(op[0] == 'I') {
				scanf("%d",&tmp);
				pq.push(tmp);
				if(pq.size() > k) pq.pop();
			}
			else 	printf("%d\n",pq.top());	
		}	
	}	
	return 0 ;
 }