http://acm.hdu.edu.cn/showproblem.php?pid=2089
杭州人称那些傻乎乎粘嗒嗒的人为62(音:laoer)。
杭州交通管理局经常会扩充一些的士车牌照,新近出来一个好消息,以后上牌照,不再含有不吉利的数字了,这样一来,就可以消除个别的士司机和乘客的心理障碍,更安全地服务大众。
不吉利的数字为所有含有4或62的号码。例如:
62315 73418 88914
都属于不吉利号码。但是,61152虽然含有6和2,但不是62连号,所以不属于不吉利数字之列。
你的任务是,对于每次给出的一个牌照区间号,推断出交管局今次又要实际上给多少辆新的士车上牌照了。
Input
输入的都是整数对n、m(0<n≤m<1000000),如果遇到都是0的整数对,则输入结束。
Output
对于每个整数对,输出一个不含有不吉利数字的统计个数,该数值占一行位置。
Sample Input
1 100 0 0
Sample Output
80
题意:区间内不含'4'或'62'的数的个数
思路:数位dp,枚举时控制一下,记录前一个数字就好了。
#include<iostream>
#include<cstring>
using namespace std;
typedef long long ll;
ll t,n,a[70],f[70][2];
ll fac(int x)
{
ll ret=1;
while(x--)ret*=10;
return ret;
}
ll calc(int pos)
{
ll ret=1;
for(ll v=1,i=0;i<=pos;i++,v*=10)
{
ret+=a[i]*v;
}
return ret;
}
ll dfs(int pos,bool pre,bool limit)
{
if(pos==-1)return 0;
if(!limit && f[pos][pre]!=-1)return f[pos][pre];
int up=(limit?a[pos]:9);
ll temp=0;
for(int i=0;i<=up;i++)
{
if(pre&&i==9&&!limit)temp+=fac(pos);
else if(pre&&i==9)temp+=calc(pos-1);
else temp+=dfs(pos-1,i==4,limit&&i==a[pos]);
}
if(!limit)f[pos][pre]=temp;
return temp;
}
ll solve(ll n)
{
int pos=0;
while(n)
{
a[pos++]=n%10;
n/=10;
}
return dfs(pos-1,0,1);
}
int main()
{
// freopen("input.in","r",stdin);
memset(f,-1,sizeof(f));
cin>>t;
while(t--)
{
cin>>n;
cout<<solve(n)<<endl;
}
return 0;
}